Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1989 W126.024 (300SE)
Joined
·
75 Posts
Discussion Starter #1
Hello,

I'm new here and hope someone can help. I'm at my wits end and want to give up on my baby.

I am the proud owner of a 1989 300SE with 280,000 miles. So far the car has been wonderful and has only needed the usual tires, fluids and brakes. But this last week, as temperatures dove and the heavy snows started, my dash lights and controls for the heater/AC stopped working. I naturally checked the fuse - which was fine but I replaced anyway. I then removed the dash panel containing the controls (not easy) and reseated the switches. Still nothing.

There is now snow up to my knees and temperatures well below freezing and I have no heat in the car. The nearest dealership or European repair shop is well over an hour away. I've tried to drive it in this weather, but the windows fog up and then immediately freeze on the inside so quickly that I can't scrape and drive at the same time.

Can anyone help me out with this? I don't even have an idea where to look.

Thank you,

Brian

PS Don't know if this is related but, my wipers have also stopped returning to their normal under the hood resting place and now stop where ever I turn off them off.
 

Attachments

·
Registered
88,560 SEC & SEL Euros, 06 S-500, 06 SRT8 Magnum
Joined
·
246 Posts
Brythonic

You said you replaced the fuse? Question did you check the Heater relay I believe its located in the engine compartment do a search on the forum type in heater relay something should come up.

Gary
 

·
Registered
1989 W126.024 (300SE)
Joined
·
75 Posts
Discussion Starter #3
I can't seem to find it. Is it the box behind the fuse box and in front of the firewall? How do I know if a relay is bad?
 

·
Registered
1989 W126.024 (300SE)
Joined
·
75 Posts
Discussion Starter #4
Ok, I'm guessing it's one of these relays. How do I know which one it is and how do I test it?
 
1 - 4 of 4 Posts
Top