Mercedes-Benz Forum banner

87 420SEL, starts and only runs a few seconds

18721 Views 41 Replies 9 Participants Last post by  waybomb
87 420SEL, starts and only runs a few seconds - Still need help

Have a 1987 420SEL. 140,000 odometer.

Start the car, rpms come up slow, idles fine, then races and shuts off. If restarted immediately, the process becomes shorter. If a wait of a few minutes, the process may take 45 seconds.

3/4 tank fuel, replaced the fuel filter today, still has same problem. The pumps are running, air filter ok, no wires seem to be off anywhere.

Any ideas on what to check?

Thanks in advance.
1 - 20 of 42 Posts
Ok, this car starts fine. Takes quite a bit of juice to turn the engine over. One <could> assume the battery would be good if the engine cranked over normally and started.


This problem was caused by a bad Battery!
Problem not found - SOS

This is my kid's car. Here's the entire serious of checks and the symptoms. I haven't worked on the car at all; I got all my info from Kev, my son.

The first thing I told him to check was the fuel filter. He did, and it was partially clogged. he replaced it.

He then told me no fuel was coming out of the tank. I told him to look at the repair cd's to make sure he was looking at the correct line. He's too smart to do that, so he pulls the tank. It was clean, the screen was clean, he was checking at the fuel filter outlet. The line coming from the tank flows fuel freely.

I am sure this is not a fuel problem.

He had the car at a buddy's shop. They put a real battery load tester on the battery and it failed miserably. Replace battery. Thats seemed to help. He went to pick up the car and a block away from the shop, the car dies again.

They test the alternator. It is marginal. They replace the marginal alternator. Seems fine, until he drives away.

So now I get involved and visit the place he has the car.

here's how it goes:

Cold start, fires right up, idles fine, and at around 50c coolant temperature or so, the idle jumps up to about 2200 rpm or so. It runs like this for anywhere from 15-45 seconds, then abruptly shuts off. It doesn't spool down slowly; it shuts off.

If restarted immediately, it jumps up in rpm almost bright away, and dies after about 15 seconds.

While in this process, I sprayed started fluid into the air valve. The engine did not pick up at all in RPMs and died. So, something electrical.

What could cause the engine to shut down electrically AND cause the rpms to jump up for 15-45 seconds? Does anybody here have the suspect controller we could borrow and try out, and then buy if needed?

If after the first event, the car is allowed to cool down, it takes longer for the process to occur. So, somehow, this is related to coolant temperatureas well.

He had a known good OVP and tried it. Nope.

What do you think the issue could be? I am not around to help him, but I'd like to save him some money. He's going to tow it to a Euro-car repair place. I can just see the $$ racking up and he doesn't save money like kids should.
See less See more
Thanks for the reply. My son "newbenz2" just registered here, so hopefully he'll contact you about the parts.
He says that the fuel pressure was checked today. When the car is running, the fuel pressure is something like 100 psi. When this failure process starts, the pressure drops to 45psi.
I am not sure where they checked it, but I forwarded a PDF I found on this site that outlines how to check fuel pressure. I'm sure he'll follow that procedure.

Any thoughts?
Looks like all the various checks are ok, until the idle races. It then drops to 45psi.

Elrojo, I sent a PM to you and mclare about the parts.

Here's some pof what I sent:

He has the car at a friend's dad's shop, but they are not familair with Benz. They have been doing a lot of searching here, mbworld, mercedesforum, and peachparts, plus, they ahve aldata.

They have determined the issue to be either the fuel pump relay or the OVP. Elrojo suggested the idle control , the Fuel pump relay, and a control under the pax carpet

I was hoping that one of you had extra working used parts, or, between the two of you, the parts.

I hate throwing parts at it, but looks like the thing to do at this time as I am out of town and can't help. Even though on this one, I am lost.
See less See more
Thanks everybody for staying with us through this. My son is working on this issue without my being there.

Thank you ElRojo and Mclare for trying to find some parts for us.

Here's what he tells me today. If the problem occurs, and the cars dies, and the engine is restarted, it will race and die again, as stated above,

He swapped the OVP out, the Fuel pressure relay out, and some other controls out, same problem. Then he jumpered the fuel pump relay. No more problem.

So, something is dropping out the run signal to the relay.

Any ideas????

Again, thanks everybody!!!!!!!
See less See more
He used one from an alledged running car that is being parted out.

Any idea what all controls the FPR and the items in series with the control? If it were a simple relay, it would only need 4 pins - control +, control -, power supply in +, and power supply out +.

I just spoke with my son and they are tracing it out now, but any guidance would be appreciated. They are using aldata schematics, but none are experienced techs.

And the FPR came from a known reputable source. I am guessing it is not the FPR. What is odd is increase in idle for a while before it dies. It runs at a high rpm (2000-2500) for at least 5 seconds before it dies. When I was in town and stopped by a couple of weks ago, it ran at high idle for a good 20 seconds before it quit.

When it started to quit, I sprayed ether into the throttle hole with no increase in idle. Kinda leading me to beileve it is electrical in nature. If it still had spark, but no fuel, the ether should have kept it running. Or not? When jumpered, does the FPR feed current to anything else?
See less See more
Glad you made it here Kev.

You NEED to get a list of what was checked and post it here.

Everybody else, on this current thread in the 126 section :

they talk about grounding out the temperature valve that puts the system into closed loop. Kev's car seems to only exhibit the symptoms once its reach about 50c.

Why would the FPR be cut off once it goes into closed loop?
Now the engine runs on starting fluid when it does the dying thing???

<Could> it be possible the new-used FPR you got was also bad?

Take one of the two apart and resolder all the connections. Maybe your bud can do that while you are at work tomorrow?
Can somebody send or point me to a resource that would list the appropriate values for the pinout of the FPR socket, in cold mode and closed loop?

1987 420sel, all stock

My son had the car towed over here.

I took one of the Fuel Pump Relays and one of the OVPs apart. Both clean.

I plugged in both open ones, attempting to watch the contacts vs dying.

The car started right up. It's been in the 20s here the last week or so, and it had not been started for a few days.

Idle is about 1100 cold, charging at 13.97 and dropping over time to about 13.75 and staying fairly steady there.

It is fine through 50c, 60c, but up around 70c, the idle jumps up to about 2200 and stays there for a while. Then, the idle starts to settle down, but the the FPR contacts open and it dies.

I did this a few times, the last couple with some ether. I can keep it running with ether, so not an ignition problem.

Then restarted, and the idle jumps around 1100-1500 all on its own. Never settles below 1100. When it jumps up to about 2200, it will do so for a while, then the FPR kicks out and car dies instantly.

Then I took the fpr out, and jumped it so it would run the pumps without the fpr. It eventually goes to 2200-2500 and does not die, nor does the rpm drop.

So, the car will continue to run with fpr jumpered, but the idle speed is very high, up to 2500 rpm.

When at 2200 rpm, disconnected the black box in the footwell, and the idle jumped up. Reconnected, dropped back down to the 2200.

Tried a different one, same indications.

Any Ideas?

I've searched all sorts of terms and must have spent 15 hours reading old posts. I can't seem to find one relating to this issue.

See less See more
I'd suggest you listen for the fuel pumps after the car stalls-- if they are still running (humming), then it seems that the FPR is still doing its thing. If not, then I suggest the Jetronic control is doing something to shut down fuel supply after the "B" path signal. I'm not sure how this would happen, as I'm still a bit of a rookie when it comes to understanding the ins and outs of the CIS controls. Check these links out-- they might be of help..
I disassembled one of the fprs (either has the same symptom). I could see the contact lever move as it dies. My son was under the car with his hands on the pump and we coordinated our findings. The lever moves and the pumps stop and the car dies.

With the FPR jumpered, it no longer dies, but the engine is racing at above 2200. It seems as if something is causing the idle to jump way up, and then kill the fuel pumps.

I'll read through the links.

Thanks alot.

Give me a few minutes to digest it and I'll try some things and report back.

Oh, one more thing. When idling around 1100 or so (it doesn't sound like 1100, but the tach shows 1100), the idle will kinda jump up and settle back tgo 1100, sometimes quickly in succession.
Or sometime s it will jump up a few hundred rpm and settle back down.
Anybody know what the auxiliary air valve looks like on this car (1987 420sel).
Ok, so I went out and found the idle control unit. Thew black box mentioned earlier must be the CIS control unit.

I started it up, I pulled out the ICU and the iidle jumped up. I plugged it back in and the idle settled down.

I unplugged the CIS and the idle dropped. Plugged it back in and it went back up.

Now, whe the engine was warm and I disconnected the CIS, the idle jumped up, not down.

Any ideas?
I have two OVPs, one I disassembled and one not.

With either of them, if I pull it out, the idle goes up. If I plug either back in, the idle, just as I plug it in, jumps up maybe 100 or so rpm for a split second, and then settles back down to the indicated 1100 rpm.
I found what the ICV was. I took it off and inspected the inards I could see. Seemed fairly clean.

I unplugged it after I installed it. I started it up and the idle was at about 2200. I plugged the ICV back in, and it dropped back down to 1100. Does that tell anybody anything about the problem?
So I took it back off. I spayed ether into it and it came out the other end. I then applied 12vdc to the plugs, it clacked close. I sprayed ether in with it closed. The ether did not leak out. I removed voltgae, it all came out.

I put it back on the engine and started the engine. Isle down in the 900-1000 range!

Anyway, have a dinner date and gotta go. More tomorrow.

Going to pick up a bunch of gumout and clean the heck out of it.

Back at it tomorrow...........
Where's the CIS module you unplugged located?
In the pax footwell, on the right side, behind the kickpanel.

The idle control relay is in that same footwell, but under the carpet, above a couple of aluminum covered controls of some sort.
1 - 20 of 42 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.