Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1984 Mercedes Benz 300SD
Joined
·
57 Posts
Discussion Starter #1
Hey guys please help.. i have a 1985 300sd mercedes benz and the car won't turn off after the ignition is off .. it takes like a min or 2 to turn off
i know it might be vacum but i don't know which is .. can some tell me or show me a picture of the vacum that i need to replace please.. thank you very much.. Danny :confused:
 

·
Registered
1981 300 SD, 1994 C280, 1990 560 SEC
Joined
·
618 Posts
So yes it is probably a vacuum issue. The engine vacuum system shares the same source so their isn't a vacuum to replace as such, you have to figure out what is not working in the system. Start by testing your shutoff valve. Hook up a vacuum pump to the hose going to the shutoff valve. Apply vacuum and the vacuum should hold. If it doesn't then your shutoff valve is the issue. Sounds like you have a slow leak or vacuum supply issue. If your shutoff valve holds vacuum then you want to make test the vacuum supply coming from the main vacuum line. If that is good then you have a leak probably around the ignition.

I've had this problem twice. First time it was the shutoff valve. Second time I had to rebuild my vacuum pump. Let me know if you have more questions.

Here's a link showing how to replace the shutoff valve:

How to Repair Your Shutoff Valve

and the Mercedes manual on the topic.
 

Attachments

·
Registered
2013 MINI Copper S Clubman, '84 300CD-weekend car
Joined
·
10,152 Posts
I had the same issue and the shut off actuator checked good, but I had oil in the line between it and the ignition switch.

I replaced the actuator and the problem is solved.
 
1 - 3 of 3 Posts
Top