Mercedes-Benz Forum banner
1 - 3 of 3 Posts

·
Registered
84 300D Turbo
Joined
·
56 Posts
Discussion Starter · #1 ·
60K mile 84 300TD; 3rd starter. After turning ignition key to "start", starter engages and engine turns. Engine stops turning after 10-15 seconds, starter disengages and starter continues to run. It will not stop unless the battery is disconnected. New starter did the same thing after 1 week. Is there and ignition switch problem or starter solenoid problem? or another cause?? Any help greatly appreciated.
 

·
Registered
1984 300CD
Joined
·
2,705 Posts
Have you tried using a jumper on the starter instead of the switch? There's a small black plastic box on the rt fender well just forward of the battery. It has a little lid just for this purpose. Jump the small and large screws next to each other. This by-passes the switch. If it doesnt stop when you stop it 's not the switch and perhaps it's the solenoid.[8D]
 

·
Registered
84 300D Turbo
Joined
·
56 Posts
Discussion Starter · #3 ·
Thanks for the info. My wife was driving the car when this happened so the battery went dead after the starter ran for 30/40 minutes. I recharged the battery and the starter started running again but the bendix was not engaged. I disconnected both the wires at the terminial and the starter still ran. I'm thinking its the solenoid too but it seems too coincidental that two rebuilt starters did the same thing. That's 3 starters on a 60K mile car. Maybe that's the quality of re-built starters but I was concerned there was something else going on.

Local parts place is providing a new starter today so will see how it goes. Glad I got the life time warranty. Appreciate your time.
 
1 - 3 of 3 Posts
Top