Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
CJ,300SD,SJ,TDIJett
Joined
·
7 Posts
Discussion Starter #1
Dear Experts,

Our pristine little beauty, '82 380SL, appears to be running a little too rich but I think it's more than that simple.

It smokes black heavily when it's started cold, also smokes bad when it's hot if I rev up the rpms in park or neutral - not that we do this.

We chanaged the injectors, frequency valve, oxygen sensor and prior to that the spark plug wires and plugs.

There's no freon in the a/c system if that makes a difference.

Thanks, Aleks
 

·
Always Remembered RIP
Joined
·
520 Posts
Possibly worn valves or seals allowing oil to enter the head.
As a general rule black s...


Possibly worn valves or seals allowing oil to enter the head.
As a general rule black smoke is usually oil, blue is fuel and white/clear water.
 

·
Registered
350SLC, 500SLC, 300TE, 190E2.3 Sportline
Joined
·
690 Posts
Re: Possibly worn valves or seals allowing oil to enter the head.As a general rule black s

Possibly worn valves or seals allowing oil to enter the head.
As a general rule black smoke is usually oil, blue is fuel and white/clear water.
Black smoke is usually rich fuel mixture. Blue is usually oil. White can be water or very bad oil problem, among others.
 

·
Registered
CJ,300SD,SJ,TDIJett
Joined
·
7 Posts
Discussion Starter #4
Black Smoke -380 SL

Dear Benz Brothers,

We found the problem to be the warm-up regulator[:O].

It's the aluminum device staring you in the face at the front of the engine just left of center.

[:D]She is running smoother than smooth.[;)]

The component was about 550 USD. Let me know where I should be getting our parts if you will?

Aleks
Windsor, Ontario, Canada[;)]
 

·
Registered
CJ,300SD,SJ,TDIJett
Joined
·
7 Posts
Discussion Starter #5
black smoke - 380 Sl

Thank-You Benz Brother HECKFLOSSE.

found it to be the "warm-up regulator"

Aleks
 

·
Registered
Joined
·
19 Posts
black smoke

I have replaced just fuel distributor, spark plugs, fuel pumps, OEH valve and still get blck smoke after a while may be 15 miles. Any sugestions. In the morning the car smooth as a baby's a.. but after 10 to 15 miles black smoke develops at all speeds. I am contemplating to replace the O2 sensor. Any sugestions?

Thank you
 

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,151 Posts
Aleks,
GERMANSTAR .... I paid $225 plus a core charge of I think $25.00. Plus shipping of I think $25. All US funds. To Barrie Ontario. The dealer wanted $1250.00 and my first born.
 

·
Premium Member
87 300SL "Roadster" 86 420SEL "Limo" 89 420SEL The "New" Limo 87 190E 2.6 fact bodykit
Joined
·
1,575 Posts
tungsten c said:
I have replaced just fuel distributor, spark plugs, fuel pumps, OEH valve and still get blck smoke after a while may be 15 miles. Any sugestions. In the morning the car smooth as a baby's a.. but after 10 to 15 miles black smoke develops at all speeds. I am contemplating to replace the O2 sensor. Any sugestions?

Thank you
It would help if you say what model you have. I had a similar problem.

As above try the cold start injectors and check your fuel for contaminants like rust or water.

If I had done this first it would have saved me a fortune.

Good luck
 
1 - 9 of 9 Posts
Top