Mercedes-Benz Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 1982 w123 300D turbo diesel automatic. I have searched for threads about problems like mine but came up empty handed. Basically I came up to a red light the other day and when I let off the brakes to move ahead the car didn't move, gave it a bit of throttle and nothing. Put it down in L and it would not move..almost like it's in reverse and 1st at the same time. Has anyone had this problem or have any idea what it could be? Vacuum line to the trans holds Vacuum well with no leak down. Also had a weird vibration when downshifting in traffic. I assumed it was the known bad driveshaft hanger bearing but maybe it's related
 

·
Registered
W123 300CD, W123 300TD, W202 C250D Turbo
Joined
·
645 Posts
I assume you have a 722.3xx transmission.

Assume:
  • Trans oil level is OK
  • Gear selector linkage is all OK

Then I suspect the main oil pump in the trans has failed so you are getting no pressure to pull in the bands.
 

·
Registered
1984 300D
Joined
·
5,513 Posts
I have been a member of various mercedes forums and have not read of your exact problem.

There is plastic bushings at the base of your shifter and there is also 2 plastic bushings on the linkages. They are inexpensive if you get generic parts on eBay. I did that like 6 years ago and the generic parts have caused no issues.

A loss of all forward gears but reverse still works is a symptom of a broken B2 piston and or a broken B2 band. There is also a lip seal there and when the B2 piston is replaced you get rid of the aluminum bushing and replace it with a nylon one as of course a new lip seal.
There is an updated B2 piston to replace the old one. While my B2 piston broke it was clear that it had been grabbing on the old aluminum bushing instead of sliding smoothly.

A year before my B2 piston broke I was occasionaly getting no shifting into first gear. Changing the Filter and Fluid cured that for about a year till the piston broke.
 

·
Registered
1984 300D
Joined
·
5,513 Posts
I have not read of it for a long time but in the past people have found broken springs inside of their control body. But, it is the last place to look.
 
1 - 6 of 6 Posts
Top