Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
so i know there are plenty of 123's with this problem,but it seems noone ever asks the right questions.so here it goes.I inherited this boy from my mentor and ever since i got him on the road he's had tranny problems.Lagged shift into drive and reverse,also slips in reverse.And no fourth gear.Then after a while the trans wouldnt go into 2 and 3 but the lag in 1st is gone.Also, hesitation between 1-2 is followed by a clacking sound.So i know about the vaccumm modulator and bowden cable.What i was wondering is this a k-2 spring problem and is it fixable by a home mechanic?thanks for the help.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
i changed the tranny fluid and filter bout a month ago, and it is actually what smoothed out 1st, there were no traces of fragments,but all the other issues still remain. original trans.#722.118, new engine, but still matching#617.912, factory warranty job.original mileage is 312,000, motor mileage is about 46,000.And yeas i am quite good at finding used parts that i need.its just so hard to find this car, they must not have made many with out turbo.thanks so much fellow gear heads.
 

·
Registered
Joined
·
91 Posts
Ouch. Funny enough, I just had the same problem last week, at 314,000 mi. with my original tranny. Started slipping out of R, then 1st. Unfortunately, it was no minor problem- a transplant was required. Set me back $1350.00. parts & labor.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
He has actually never had any other gears, but reverse slip.it just wont shift to second.And if a transplant is required, what are my options, id really rather have a stick, is this possible?Non turbo remember.and if there is no modulator valve, how is the vacuum regulated to the tranny?if i wasnt already loosing hair, id be pulling it out.
 
1 - 7 of 7 Posts
Top