Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
HELP!!!!!!!!
First of all I had a leak on the auto trans that I sorted out,I changed the sump pan gasket, the kickdown solenoid "o-rings" and the transmission fluid filter. Everything went fine for about 4 weeks or so and a new problem has occured.
Travelling down the road after about 15 miles or so the car seems as if its stuck in one gear, now if I stop completely and shift the gear lever from 'D' to anyother position thats when the car decides that it ain't moving anywhere?? the stupid thing is that if I leave it for a few minutes then the trans works as if there's nothing wrong with it at all!!? Its as if the box is waiting for the fluid to settle back down before going further but, the manual I have states that when you do a fluid change that this type of box takes 5.5 litres of ATF, so 5.5 ltrs go in and this is what is happening? When it gets stuck it seems as if its slipping - high engine revs and not alot of speed.
I've been reading a few messages on the site, abd a couple of people go on about code reading? I know you get fault codes on the car but is it something that flashes up on the dash or is it something that you actually look for by pluging in a machine of somesort? I've got to be honest, this is really getting me down at the moment cos' a mercedes is what I've wanted for a long time and this is really doing my head in !! Any help would be greatly appreciated.
Thanks
Finchy
 

·
Registered
Joined
·
181 Posts
Really sorry to hear that you auto box is playing up recently.
Anyway, I am no mechanic and I am only able to tell you that the diagnosis is when you plug in a machine (forgot the name), and it will show up the fault codes of your car.. The faults do not show up on the instrument cluster..

Jeff
 
1 - 2 of 2 Posts
Top