Mercedes-Benz Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Where do i start ? 93 600 sl . Driving down the road the car suddenly has no power but has minor accelleration.I will pull into the side,switch off the engine,wait a few seconds,restart and the problem is gone.Happens at least once a day.Have had the problem for 5 years.Have had the car in 4 mercedes dealers.Still have the problem.I give up.The car is in Ireland.
 

·
Registered
MB SL600, MB 380SE, Suzuki Grand Vitara, 38' Chris-Craft, Volvo V70XC, and my own two feet...
Joined
·
4,131 Posts
Getting any ASR/ABS/CEL lights?

And here's the million dollar question (well...$3k anyways): Have you replaced the wiring harness yet?
 

·
Registered
MB SL600, MB 380SE, Suzuki Grand Vitara, 38' Chris-Craft, Volvo V70XC, and my own two feet...
Joined
·
4,131 Posts

·
Registered
2000 Obsidian Black Metallic Mercedes SL 320 V6 (SOLD) 2012 E 350CDI Cabrio 265 PS
Joined
·
4,544 Posts
Hi jwhyte and welcome in our big family. First of all I may suggest you to fill your profile with your car, its year and your location to help us help you in the best and quickest possible way.
Back to your problem, I have the feeling that Chris is right because usually for production years between about 1993 and 1995 Mercedes cars tend to have wiring harness problems since the wires insulation in the harness becomes brittle and every kind of electrical gremlins arise.
If I were you I'd start investigating in that direction and if unfortunately you discover that's the problem you are facing a bill of at least 1000 €.
While you are at it you should have a look at the speed sensors just in case.
Oh and when the car looses power as you describe probably locks the gearbox in 2nd gear too doesn't it? That's the typical LHM (Limp Home Mode).

Good luck.

Cheers.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Thanks for you comments.One additional problem i discovered,is that the speedo resets itself back to zero.This seems to start just before it starts its limp mode.One time the speedo was working backwards.and the mileage goes to zero.Wiring harness,its the only part that has'nt been replaced.
 

·
Registered
2000 Obsidian Black Metallic Mercedes SL 320 V6 (SOLD) 2012 E 350CDI Cabrio 265 PS
Joined
·
4,544 Posts
Thanks for you comments.One additional problem i discovered,is that the speedo resets itself back to zero.This seems to start just before it starts its limp mode.One time the speedo was working backwards.and the mileage goes to zero.Wiring harness,its the only part that has'nt been replaced.
jwhyte in the 3 years I've been on the R129 forum if memory assists me your speedo problem is a first to be honest so I don't know in which direction I could address you but my instinct given your year really points me towardws the wiring harness once again. I'm telling you I might be wrong but that's what my instinct tells me.

Cheers.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Yes. I think i agree.The cost for this is savage.In the order of 3000 euro in Ireland with an MB dealer.The mindset here is keep replacing parts till you find the problem and you keep paying.On the fact that i have replaced everything else,the wiring harness i the only major part i havent touched.I will go and get a price.I will keep all informed.
 

·
Registered
2000 Obsidian Black Metallic Mercedes SL 320 V6 (SOLD) 2012 E 350CDI Cabrio 265 PS
Joined
·
4,544 Posts
jwhyte I suggest you to dump the dealer as a part source because there are plenty of places around the world that could sell you parts for your Mercedes and not making you sell your own body parts to pay the price. Ebay is one Parts.com - For every part of your life is anther and if you use the advanced search feature of the forum you can discover plenty of places willing to sell you spared at a fair price. As you can see in my profile I'm Italian and I've been buying spars for my previous 2000 SL 320 and for my present 2003 CL 500 from Germany to California despite the notorious terrible and slow Italian customs.
Again jwhyte to help us help you int he best and quickest possible way I suggest you to fill your profile with your car its year and your location.
It's quick, needs little effort but it's a huge time saver :).

Good luck with your car.

Cheers.
 

·
Registered
MB SL600, MB 380SE, Suzuki Grand Vitara, 38' Chris-Craft, Volvo V70XC, and my own two feet...
Joined
·
4,131 Posts
Yes. I think i agree.The cost for this is savage.In the order of 3000 euro in Ireland with an MB dealer.The mindset here is keep replacing parts till you find the problem and you keep paying.On the fact that i have replaced everything else,the wiring harness i the only major part i havent touched.I will go and get a price.I will keep all informed.
The price is hideous.

But look at the bright side, once it's done, you don't have to mess with it again. They fixed the insulation in the new harnesses...
 
1 - 11 of 11 Posts
Top