Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
300CE-24V
Joined
·
12 Posts
Discussion Starter #1
Hi guys. So after long time I've finally found working 722.5 transmission for my 300CE-24V. But now I have a problem that 5th gear is not engaging.

I know how 5th gear is engaged on this transmission so I just want to know from where the vehicle speed signal is taken.

And yes I know that car starts in 2nd gear :)
 

·
Registered
W208 CLK200K,R170 SLK230K,R107 350SL,W124 300CE24,W124 300D
Joined
·
3 Posts
Hi ... Have you rectified your problem?

I own W124 300CE 24, I have similar problem. Car does not shift to 5th gear as it should. Otherwise the car running smoothly. Just that i have noticed the the gear shifts are a bit sluggish 'delayed' shifting to lower gears.

Probably you should look to other threads... i have read about transmission control unit and solenoids. This might help you.
 

·
Registered
300CE-24V
Joined
·
12 Posts
Discussion Starter #3
hi. Well the problem looks to be in vehicle speed signal. It goes from transmission to speedometer from where it is converted to pulse signal which goes to 5th gear control unit (located behind battery).

I've found that speed drive gear in transmission is broken so need to fix this.

If your speedo is working then you have different problem. Maybe in 5th gear switch which is located in gear shift lever.

You can find out if your problem is with sensors or with solenoid by removing 5th gear control unit. Without it the transmission goes from 3th to 5th (skipping 4th).

And about issue with downshift, check your throttle cable to transmission if it's properly adjusted .
 

·
Registered
300 CE 24V Sportline
Joined
·
869 Posts
hi. Well the problem looks to be in vehicle speed signal. It goes from transmission to speedometer from where it is converted to pulse signal which goes to 5th gear control unit (located behind battery).

I've found that speed drive gear in transmission is broken so need to fix this.

If your speedo is working then you have different problem. Maybe in 5th gear switch which is located in gear shift lever.

You can find out if your problem is with sensors or with solenoid by removing 5th gear control unit. Without it the transmission goes from 3th to 5th (skipping 4th).

And about issue with downshift, check your throttle cable to transmission if it's properly adjusted .
Firstly, clear fault codes from MSG. Then change the 4th/5th microswitch by the gear level - it's only a 30 Euro part and, when faulty, causes the MSG to record faults and go into "skip 4th" mode.

Make sure fluid and filter are 1st class - ensure that both box and TC are drained and refilled.

Mine's been good ever since I did all this.

RayH
 

·
Registered
W208 CLK200K,R170 SLK230K,R107 350SL,W124 300CE24,W124 300D
Joined
·
3 Posts
:thumbsup: Thanks guys... ill go ahead and try it out soon. Thank you for the advice. Hope it works out well.
 
1 - 5 of 5 Posts
Top