Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
1988 560SL
Joined
·
2 Posts
Discussion Starter #1
[?]I recently bought replacement hinge covers (chromed plastic) but I'm having a lot of difficulty fitting them. Has anyone been through this? I put them in position, but no amount of pushing or other persuasion will get them to snap into place.
Thanks
 

·
Registered
1989 560sl
Joined
·
3 Posts
re: hinge covers

You have to make sure that the hinge covers came with the lynch-pin-like metal retainers. Otherwise, they won't stay.
 

·
Registered
1988 Black/Black 560SL
Joined
·
35 Posts
You have to make sure that the hinge covers came with the lynch-pin-like metal retainers. Otherwise, they won't stay.
I was wondering if anyone knows where a picture is for these lynch pins. This is my second SL that has had these missing. Is there a part #?
 

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,166 Posts
No.I don't have the part number.
But that arrangement will always be a disappointment.


Here's my fix...........
 

Attachments

·
Registered
1988 Black/Black 560SL
Joined
·
35 Posts
No.I don't have the part number.
But that arrangement will always be a disappointment.


Here's my fix...........
Thanks Nobby ~ that's a great idea - I am a sewer so I feel a little dumb that I didn't think of that.
 

·
Registered
1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Joined
·
3,513 Posts
You've also got to make sure any bits of the old cover is not broken off and hiding in the attach points.
 

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,166 Posts
You can go a long way with a duct tape, velcro and a can of WD-40.
 
1 - 8 of 8 Posts
Top