Mercedes-Benz Forum banner

21 - 23 of 23 Posts

·
Registered
1976 406 w/ backhoe and dozer blade, a small collection of implements too
Joined
·
1,416 Posts
Have you tried messing with the sensor? It's easy to get to for sure. Right on the water pump. Perhaps the engine transplant did something to it. Or is this a new sensor that came on the new motor? Perhaps it's 24V and not happy with the 12V system?

Not sure how that would work exactly but going for low hanging fruit.
 

·
Registered
1985 416 DOKA mid-mounted Rotzler winch, 1984 U1200AG
Joined
·
443 Posts
The sensor is the easy one!

I was having this problem before the engine swap. I ordered a new sensor from Von and put it in while we were doing the engine swap. I could have gotten a bad sensor from Von, but in that case would rapping sharply on the gauge still help?

REALLY want to have a fully working temperature sensor!
 

·
Registered
1985 416 DOKA mid-mounted Rotzler winch, 1984 U1200AG
Joined
·
443 Posts
Update to temperature problem.

I tested two senders resistance and they are good. At some point the wire from the gauge to the sender was shorted to the exhaust manifold. (I think this did damage to my temperature gauge.) When the wire is unhooked from the sender the gauge is pegged low when the gauge is hooked to the sender it is pegged high.

The temperature gauge is nothing more than an old school ohmmeter with a temperature scale instead of an ohm scale. I suspect the shorted out time damage that sensitive ohmmeter.

I tested my theory by adding a variable resister in between the sender and the gauge. With about 700 ohms of resistance added into the system it seems to fix the gauge.

I have a little more fine tuning to do....the potentiometer I had was not linear or fine enough to figure it out completely. But until I tip the cab back up in the spring to install an AV turbo the resistor solution should be good enough. At that point I will install a new temperature gauge and cut the resistors out of the system.

A diagram I got here on Benzworld was the key to figuring this out...thanks!!!
 
21 - 23 of 23 Posts
Top