Mercedes-Benz Forum banner

21 - 25 of 25 Posts

·
Registered
97 SL500, 98 E320 Wagon, 2002 ML500 - former W108/W112/W114/W123/W124/W126/W140/W220
Joined
·
6,232 Posts
Discussion Starter #22
Dan, do you have a link / contact info for the ETA rebuilder you used?

:)
His name is Don Roden and his company is RFC Electronics, located in Hillsboro, AL. He works through eBay and his handle there is https://www.ebay.com/usr/at-hiker1

Don did a great job, turned my ETA around in a day and responded promptly when I inquired as to the reasons for failure and what had to be repaired/replaced. The price was quite reasonable, I felt, at $279 for a rebuild of my ETA, For another $100 you can buy one outright for most part numbers, it appears.

I'm pleased to report that the rebuilt ETA appears to have resolved my issues. I haven't road tested yet, but it started up immediately, idled right down to spec, and there are no warning lights.

I'll be road testing shortly and will report back.

Dan
 

·
Registered
97 SL500, 98 E320 Wagon, 2002 ML500 - former W108/W112/W114/W123/W124/W126/W140/W220
Joined
·
6,232 Posts
Discussion Starter #23
Gave it a short road test up to about 50 mph. Ran perfectly, lots of power, everything seems to be good. No warning lights or problems.

I’m calling this done.

Dan
 

·
Registered
1993 400E
Joined
·
309 Posts
Hi, I also have a 1993 400E. I’m assuming it has ASR as there is an ASR light that has come on twice about a week apart. I have already sourced upper and lower harnesses. Thinking to looking for an ETA to be safe.

Do you know what the part number is?

Is rebuilding the way to go?

Thanks,

Andy
 

·
Registered
Buncha W124's
Joined
·
2,039 Posts
I posted the ETA part numbers in your other thread:

 
21 - 25 of 25 Posts
Top