Mercedes-Benz Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
114 Posts
If the car runs well, but has trouble starting hot, you may need a new fuel accumulator.
I had no trouble starting cold or hot, but after it ran then sat for 45 minutes to ~1.5 hours it had a helluva time starting. Had the fuel accumulator replaced and voilá no problems since.
 

·
R/C107 Moderator
Joined
·
31,588 Posts
Hello again.
Making good progress on my 380.

I removes the chrome plates see image.
Underneath it I found a rubber part the had fallen off see image.

Does anybody know where and how its hold in place ?

Thank you for your help View attachment 2606000 View attachment 2606001 View attachment 2606002 View attachment 2606003
107 727 11 30 right 107 727 12 30 left. Here is a Thread on it. They are shown in the wrong place in the EPC. https://www.benzworld.org/threads/seal-bumper-part-number.1643565/post-5176347
 

·
Registered
Joined
·
17 Posts
Hello.

I’m have 3 questions that i was hoping to get some help with.

1/ If my 380sl is not in use for two weeks or more it start leak transmission oil.
If I drive it its bone dry..Not even a drip.... Any idea ?

2/ I’m looking for some vinyl to do some reapolsetry work on some of the panels.
Does anybody know of a place that sells the right kind of vinyl?

3/ in the image are two small plastic caps that has come off my car.
Where do the belong?
View attachment 2604683

Thank you

Nicolai
Tandy Leather has a table of leftovers or whatever for $50, This is where all of my leather upholstery comes from , and I choose what they have that day

They also have high-end vinyl and everything else.
 

·
Registered
Joined
·
17 Posts
Great thank you,
You guys are so helpful!!

So now i came up with two more questions.

1/ i like to redo the wood around the gear shifter.
How do you get it out?

2/ When my car is cold or very hot is starts in less then 1-2 seconds.
But if i shot it off, and leave it for 5-10 min its hard to start and it does not fire on all 8 cylinder.
It takes a couple of seconds and it need a bit of help from me pushing the gas peddle.
Any idea ?
The hot-start problem is the fuel accumulator, a rather easy to swap part, it is like an oil filter with a spring loaded pressure plate. when the engine shuts off, the spring-loaded plate goes into action and keeps pressure on the system, until the system cools, then the spring pressure has dissipated. YOUR spring pressure dissipates too fast, so you need a new one - https://www.eeuroparts.com/Parts/68699/Fuel-Accumulator-0004760821/
 
21 - 25 of 25 Posts
Top