Mercedes-Benz Forum banner
1 - 10 of 10 Posts

Registered
1993 Mercedes Benz 320CE
Joined
6 Posts
Discussion Starter · #1 · (Edited)
Hello everyone asking for your help for my 1993 320CE coupe M104.992 Engine

Engine stalls while idling and hard acceleration. Parts were replaced already:
Throttle body
Cam sensor
Maf sensor
VVT adjusting gear
Fuel filter
Fuel injectors
Spark plugs

Thank you 馃檹
 

Premium Member
'99 S420 125K
Joined
1,864 Posts
What is the mileage on the vehicle?

It may be a loss of fuel pressure causing these symptoms.
At some point the fuel pump and accumulator will need replacing.
 

W163 and General M Gremlin
Joined
17,002 Posts
Tested with known good oem OVP?
 

Premium Member
'99 S420 125K
Joined
1,864 Posts
Air, fuel, spark...
Sounds like fuel issues to me.
You might have bad plug wires or cap and rotor, distributor issues, as well.
 

Registered
'95 E300 DIESEL, '91 600SEL, '92 600SEL
Joined
19,777 Posts
I don't see coils or spark plug cables. The ENTIRE ignition system (3 coils, 3 spark plug cables, and 6 spark plugs) are disposable with a very finite lifetime.

And the ONLY proper spark plug for that engine is Bosch F8DC4 and nothing else. Ditto on only using Bosch coils.
 

Registered
1993 Mercedes Benz 320CE
Joined
6 Posts
Discussion Starter · #10 ·
I don't see coils or spark plug cables. The ENTIRE ignition system (3 coils, 3 spark plug cables, and 6 spark plugs) are disposable with a very finite lifetime.

And the ONLY proper spark plug for that engine is Bosch F8DC4 and nothing else. Ditto on only using Bosch coils.
2 of the coilpacks were replaced already. Brand new 3 high tension wires but the spark plugs i installed was NGK brand
 
1 - 10 of 10 Posts
Top