Mercedes-Benz Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Help! Sometimes (usually not this first time of the day) my wagon won't start-I hear a clicking sort of noise from inside the dash behind the acc controls-no starter or solenoid action at all-just a few clicks from the dash. Any ideas? Does this car have relays in the dash? I'm still waiting for MB to send my CD roms!!
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
Hi John,<br> <br> I had intermittent starting problems that cropped up with the previous owner of my '85 300tdt. The problems occurred almost exclusively following a long drive (as opposed to around town short stuff) and consisted of the clicking sound you describe. If I waited a few minutes, it would start up fine as if nothing was wrong. The PO had replaced the ignition switch in an attempt to correct this and provided me with a rebuilt Bosch starter on the theory that it was a solenoid-related issue. I had the new starter installed and the problem still persisted. I then had all related grounds checked and tightened, which seems to have alleviated the problem - for the 2 or 3 weeks since. I don't know if you're experiencing similar simptoms, but take a good look at the electrical grounds. Hope this helps.<br> <br> Cheers,<br> <br> Joel
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
did you ever get this problem solved? i have the same thing happening in my 81 wagon. it will always start if i jump a hot wire straight from the starter to the battery. my battery is good, we ran a new ground strap, have new alternator, new neutral safety switch and have tried several different starter switches. <br> would appreciate any help anyone can give
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top