Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi
I have a 1988 300 sel mercedes benz, and it uses way too much fuel. It used to get 400 or so miles to the tank...now it goes about half or less. These are the symptoms:
1-start to engine with no need to push down the gas pedel
2-put in drive, push down gas pedel no respose until i push it down all the way to the floor... car hesitates, then engine revs hi then i get pushed back into my seat, the the car takes off like a bat out of hell, black smoke leaves the pipes. when on high way car runs ok, but has very strong gas smell.
3-when in idel car economy meter stays in the middle, never gets lower until i put it in park.
is there anyone out there with some mercedes knowldege?? my wallet is getting lighter every day paying for gas.
thanks
*young006
 

·
Registered
1980 300sd, 1998 e320
Joined
·
73 Posts
it sounds like it is time for a tune up. sounds to me like the timing is incorrect.
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
sounds like you have one hell of a vacuum leak as well as an overly rich situation. Could be EHA, 02 sensor.. Need some history on the service that has been done over the past year or so. Also sounds like you shouldn't be driving your car.....[:0]

Jonathan
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
It could be a leaking cold start valve or sticking airflow sensor plate and/or control plunger.
 

·
Registered
'80 500SE AMG '80 300SD '78 450SLC '00 Passat GLX Wagon
Joined
·
1,155 Posts
youngil006 - 4/28/2005 4:34 PM

Hi
I have a 1988 300 sel mercedes benz, and it uses way too much fuel. It used to get 400 or so miles to the tank...now it goes about half or less. These are the symptoms:
1-start to engine with no need to push down the gas pedel
push it down all the way to the floor... then engine revs hi then i get pushed back into my seat,
*young006
Isn't that the way you're supposed to drive?[:D][:D]
 
1 - 5 of 5 Posts
Top