Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,810 Posts
Discussion Starter #1
I just got my '77 300D back from the shop and discovered that even when the engine is stone cold in the morning, the aux fan fires right up and keeps running all the time. They had installed a new 212F switch at the thermostat housing, but apparently that didn't work right. I disconnected the switch and the fan quit running, of course. Seems the switch is the culprit, but could it be the relay? If that, where is it located? Thanks.
Hemersam
 

·
Premium Member
Joined
·
16,161 Posts
I just got my '77 300D back from the shop and discovered that even when the engine is stone cold in the morning, the aux fan fires right up and keeps running all the time. They had installed a new 212F switch at the thermostat housing, but apparently that didn't work right. I disconnected the switch and the fan quit running, of course. Seems the switch is the culprit, but could it be the relay? If that, where is it located? Thanks.
Hemersam
The relay for the aux fan is located on the driver side fender, in the black box. I don't recall which is which but the other relay is for the AC compressor.

Make sure the AC drier temp switch is not rigged to trigger the auxiliary fans to run when the key is in position 2.
 

·
Registered
Joined
·
103 Posts
aux fan

just got my car back today after getting a new ac compressor, drier, and expansion valve. running r-12. i noticed my aux fan kicked on right away. turned offf ac before engine and fan was on until i shut off ignition. my ac was out for 14 months so i dont remember if it did this before. could the mechanic have overridden or installed wrong drier temperature switch? relay shorted?
 
1 - 3 of 3 Posts
Top