Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1987 560 SEC
Joined
·
14 Posts
Discussion Starter #1
1979 300d NA

Okay now I know it's not a fast accelerating car.

But I think I may have an issue with throttle pedal / linkage.

50-80 mph acceleration when the pedal is pressed to the floor (but not engaging the kickdown) takes a while to get to 80 and the speed climbs very slow but steady and
eventually you get there.

some would say it's typical for a non turbo.

however if I engage the cruise, the speed increases from 50-80 at a much faster rate.

obviously I have some sort of pedal issue.

I've thought about removing the pedal and just using the steel rod as a test.

Any ideas?
 

·
Premium Member
1977 6.9, 1976 W115 240D, w123 300D turbo
Joined
·
43 Posts
1979 300d NA

Okay now I know it's not a fast accelerating car.

But I think I may have an issue with throttle pedal / linkage.

50-80 mph acceleration when the pedal is pressed to the floor (but not engaging the kickdown) takes a while to get to 80 and the speed climbs very slow but steady and
eventually you get there.

some would say it's typical for a non turbo.

however if I engage the cruise, the speed increases from 50-80 at a much faster rate.

obviously I have some sort of pedal issue.

I've thought about removing the pedal and just using the steel rod as a test.

Any ideas?
Take a look at the rubber joint at the fire wall. The joint damps vibration between the throttle pedal and the engine and they fail over time. When it fails you don’t achieve wide open throttle.

The cruise control isn’t affected by the joint condition.
 

·
Registered
1987 560 SEC
Joined
·
14 Posts
Discussion Starter #3
Mine has the shaft running along the firewall NOT the isolator version
as shown in the pic

2620986
 

·
Premium Member
1977 6.9, 1976 W115 240D, w123 300D turbo
Joined
·
43 Posts
Sorry, then I'm no help. All the w123's I've been around were built per your picture. Consider having a partner depress the throttle pedal and confirm that you aren't reaching the stop at full throttle. At least then you'll know if the linkage (whatever it is) as allowing the pedal to fully open the throttle. Since it is better accelerating on cruise, I expect that you are not reaching WOT with the pedal.
 
1 - 4 of 4 Posts
Top