Mercedes-Benz Forum banner
1 - 9 of 9 Posts

·
Registered
1976 W115 240D, 2014 X204 GLK350, 2012 W204 C250, 2006 W164 ML350, 2014 W166 ML350
Joined
·
79 Posts
Discussion Starter · #1 ·
Had the following dash lights all come on simultaneously. Drove it around with the lights on, under 50mph it was okay but on the highway over 50 no acceleration. But it didn't go in to "limp" mode.
Checked it with iCarsoft scanner and got the following 2 codes
P061A
and
C0034
Did some googling...but came up empty. None seem to have anything to do with ABS or ESC (ESP).
I found a site suggesting replacing the brake light switch. But then found a YT video suggesting not to.
Car Speedometer Vehicle Motor vehicle Gauge
 

·
Registered
2015 GLK350
Joined
·
26 Posts
How's the battery in car? You can get odd lights and warnings when the battery is dying and low on voltage.
 

·
Registered
1976 W115 240D, 2014 X204 GLK350, 2012 W204 C250, 2006 W164 ML350, 2014 W166 ML350
Joined
·
79 Posts
Discussion Starter · #3 ·
How's the battery in car? You can get odd lights and warnings when the battery is dying and low on voltage.
The battery is less than 2 years old. It reads 12.4 volts off and 14.8 volts when running.
 

·
Registered
Dallas, Texas
Joined
·
10,093 Posts
The battery is less than 2 years old. It reads 12.4 volts off and 14.8 volts when running.
Don't post codes without text description. There is no way to look them up.
List them by control module they were retrieved from.
 

·
Registered
1976 W115 240D, 2014 X204 GLK350, 2012 W204 C250, 2006 W164 ML350, 2014 W166 ML350
Joined
·
79 Posts
Discussion Starter · #5 ·
Took some advice from a non MB mechanic, and I charged the battery overnight and cleared all fault codes. Started the GLK this morning, no dash lights.....drove it around, same dash lights came on again, came home and got the following codes from the scanner....
Plant Gadget Audio equipment Technology Display device



I drove it again. This time hard accelerating from a stop and the vehicle went in to limp mode. Hooked up the scanner again and read the following codes....


Output device Gadget Technology Display device Electronic device
Gadget Output device Display device Gas Electronic device

Plant Gadget Display device Technology Electronic device
 

·
Registered
1976 W115 240D, 2014 X204 GLK350, 2012 W204 C250, 2006 W164 ML350, 2014 W166 ML350
Joined
·
79 Posts
Discussion Starter · #6 ·
I google the initial code the scanner read C0034 and it came back as a wheel speed sensor.
Im wondering if a faulty wheel speed sensor would cause the other code P061A and / or cause the vehicle to go in to limp mode? Any thoughts on this.
 

·
Registered
1999 E430; 2005 ML500
Joined
·
2,288 Posts
Yes. Change the front wheel speed sensors. On mine, I got a code for the left - replaced it. Problem recurred. Replaced the right and basta.
 

·
Outstanding Contributor
'17 GLS450, '14 GLK250 "Grandpa's Roadster" Project Car, 350SDL (Sold)
Joined
·
4,156 Posts
Faulty readings from the wheel speed sensors can trigger the stability control, which can then limit throttle.
 

·
Registered
1976 W115 240D, 2014 X204 GLK350, 2012 W204 C250, 2006 W164 ML350, 2014 W166 ML350
Joined
·
79 Posts
Discussion Starter · #9 ·
I ordered the ABS sensor (2049054205). It was about a $70 oem part. As soon as I get it in and installed, I'll update here. Thanks for everyone's input.
 
1 - 9 of 9 Posts
Top