Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm new here so hopefully I'm posting this in the correct section. I'm really at a loss for what to do so I'm hoping maybe someone has an idea beyond what I've already tried. This is long, so hold on.

So currently, my c63 cannot stay idling - it stalls almost immediately unless I press the gas pedal (while in park). As soon as I let off the gas, it stalls. It currently has no codes, and using an iCarsoft handheld didn't provide any useful information.

So the background:

Current modifications: flex fuel kit with larger fuel injectors, long tube headers, built transmission, custom exhaust (primary and secondary cat delete), ROW air boxes, 85mm throttle body, and Eurocharged V7 Tune.

At first, it would stall only while idling. I could turn it back on, and keep driving, so long as I didn't have to idle for very long, but this pretty quickly devolved into it having more and more difficulty staying on. Still no code though. So the first thing I tried was a new throttle body (upgraded to the 85mm) and new spark plugs. It sounded terrible turning in back on and then wouldn't even start. I bought the iCarsoft at this point, and it showed a bunch of issues related to the ECU...

So I had it towed to Mercedes (if anyone has a trustworthy Mercedes mechanic in the No. VA/DC area, let me know) - and they determined it needed a new fuel pump, new intake gaskets, and a new crank sensor. Had all of that done, still didn't fix the problem. So then they put in a new ECU, siphoned out the e85, put in premium gas, and it still wouldn't stay on. It would idle for a few seconds and stall. My hope was maybe it can't stay on because it has larger fuel injectors, and needed an updated tune. So I sent the stock file from the new ECU to Eurocharged, they send me the new V7 tune, I tune it, and it idles (never sounded right, like it was trying to even itself out but couldn't) then stalled after about 3 minutes. Now it won't even turn back on... One of my friends who works on AMGs suggested I might want to switch back to the stock fuel injectors and see if it'll run on those, but other than that, I'm at a complete loss for what to do. The Mercedes dealer doesn't know what else it could be, and it doesn't seem to be a problem with the tune from Eurocharged as I've flashed it to stock and back and it still won't start; it only stays on if I'm mid-throttle on the gas, then dies immediately when the gas pedal is released. And there are no codes. So what am I missing?

If you read all of that, thank you. TL;DR: Changed every part imaginable, car won't stay on, and refuses to throw a code.
 

·
Moderately subtle
Joined
·
12,054 Posts
Ok, so, yeah, having never used the stuff, I made a bad assumption. Sorry about that.

Having now looked up the fuel and the mod that was required, I wouldn't have had the guts to do that. Was it an MB mod or aftermarket?
 
1 - 4 of 4 Posts
Top