Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
Hi

I have 2008 GL450 with about 100k miles. I changed front air shocks and rear shocks and bags with arnott brand last august. At that time i also changed the fuse, relay and the pump. The pump was an off brand from Amazon but had good reviews. I did not change the valve block.

Recently i get the 5508 malfunction code saying i have a leak. The front of the truck is raised and holding pressure. The back looks slumped (evenly slumped) and rides rough. When i start the truck it does not sound like compressor is on.

My question is do you think this compressor is already shot? or could it be the valve block? Is there an easy way to tell either or?
I checked the relay and it is good as well as the fuse. If the compressor was bad wouldn't the rear bags still at least hold air? Also i see there might be a holding tank in the rear. Where is this located?

Thank You
 

·
Registered
Joined
·
6 Posts
Right side rear air spring won’t inflate

Greetings! Just joined the forum and thank in advance for all the expert advice.

I have a 2008 GL450 with 50k miles. Recently it is leaning a little with right side low. Looked underneath, surprised to find that lower end of right side rear air spring is not seated in the mounting hole, it is just dangling freely to the side. I am guessing for some reason that air spring was not inflated when the car was on the lift for tire rotations a few month ago, the lower end of air spring might have got lifted out of place, so when car was lowered, the end of air spring just got pushed to the side.

In any case, I removed that air spring, checked it does not leak (hooked up to compressed air, no soap bubbles), installed it back on car again.

Turn the engine on, found that air spring is soft to the touch and doesn’t inflate. Compressor appear to work since I can raise and lower front end of car, but back end always stays low. The left rear air spring is hard to the touch but seems just for residual air trapped inside. Fore I sis anything, left side wheel well was about 3-4 inch above the tire, now it stays at about 1 inch for both sides, but there is no warning message on dashboard.

Any advice is greatly appreciated.
 

·
Registered
Joined
·
1,152 Posts
Make sure the air line is tight going into that air spring. You also may want to spray both lines with soapy water to verify if they are leaking.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
I found my problem was caused by valve block not distributing pressure to the back air springs. After replacing it, rear air spring work again, but it seems calibration is off and rear end is a little lower than the front.
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
4 Participants
[email protected]
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top