Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1
Hello

I have a 2007 S550 84,000 miles with an 11/05 build date so I believe it is possibly effected by the timing chain issue, in fact the check engine light goes on intermittently, I haven't gotten it checked to see why, frankly I am afraid to as the car was running fine up until now.

When driving the car cold it literally sounds like a boat where the exhaust outlet is coming in and out the the water on a wavy day, in other words the cars engine is more muffled and normal and it goes in and out to loud again and again. In fact literally does sound like some sort of exhaust being muffled and unmuffled by a liquid because when going over a bump it sounds like suddenly the sound is muffled like a liquid inside the engine got stirred up and covered the sound.

It's very weird, it goes away mostly once the car is warmed up are a little after it is warmed up. Otherwise the car seems to be running fine power wise and mpg wise, I am wondering if anyone has experienced this or if it is related to the timing chain issue.
 

·
Registered
Joined
·
90 Posts
A worn idler gear would not cause that. Ever changed the engine mounts? Could be just the vibrations being transmitted through the body.
 

·
Registered
Joined
·
6 Posts
I have this same problem. It just recently started.

My car has given off a engine light and code of P0025. (Cam over retarded Bank 2)

Would this sound come from the magnets needing to be replaced?

Or what other issue could cause this?

Please help.
 
1 - 3 of 3 Posts
Top