Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hey all


I'm close to the end of my factory warranty and wondering if anyone w/ a 2007 model year has had the problems w/ the balance shafts ?

My dealer says he has yet to see a 06-07 C230 w/ the problem but I know there are some 2006's on the boards but I haven't seen anyone yet w/ a 2007 and this problem , mines a really late '07 ( dec)

I'm pondering buying an extended warranty through National Warranty Corp in Eugene Org as the dealer says these guys are the ones they offer and have been around for a long time and I can't find any real negative things about them and I check warranty direct which has a huge list of complaints .Cost is about $3000 ....... debating whether to do it or take the money and upgrade to a C55 ,lol
 

·
Registered
Joined
·
40 Posts
My wife's 2006 C230 has an M272 engine serial number of "....288233", engine build date of Apr 1, 2006. As I understand it this engine is in the problem range.

The TSB says the problem exists with: "Applicable Models (Not Applicable to Model 164.156, 204 or 216.386): Equipped with M272 Engine Up to Serial No. 2729..30 468993 or M273 Engine Up to Serial No. 2739..30 088611."

We have yet to have any symptoms related to this problem. We bought the car new with 11 miles on it. It now has 75K miles on it and I've done consistent 5K mile OCIs using Mobil 1 0w-40 and either Mann or Mahle oil filters from new.

Scott
 

Attachments

1 - 2 of 2 Posts
Top