Mercedes-Benz Forum banner
1 - 10 of 10 Posts

·
Registered
2006 C230 W203 SS Red
Joined
·
27 Posts
Discussion Starter · #1 ·
I have been on this forum looking for a detailed radio removal guide or post for a 2006 C230 Sports Sedan and have yet to find one. It looks similar to the 2002-2004 C230's, but the dash is a little different. I am going to be installing a Comand 2.5 in the car. I have the IPOD adapter as well. But I would like more detail on the removal of the old radio that is in my car. Any help would be appreciated. Thanks.
 

·
Registered
2006 C230 W203 SS Red
Joined
·
27 Posts
Discussion Starter · #2 ·
The comand is installed. I have posted another thread on the time zone change. The tme button on the Comand is not lit. It is confusing. Does anyone have any information as to why this like that? Thanks.
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,429 Posts
You mean the GPS is working, including the correct maps shown for your area? At least the NTG4 device would not need any time or time zone setting at this point. Are you sure you have set the date correctly, perhaps it is a daylight saving time issue?
 

·
Registered
2006 C230 W203 SS Red
Joined
·
27 Posts
Discussion Starter · #4 ·
Update

Well I mean the GPS time is off by an hour and I have the timeset button on the MCS and I know for sure the unit is an Alpine. It has the DVD and CD slot behind the monitor that flips down. The Timeset key lights up when the ignition is in the off position, and when you press the button in order to set the time, need to put the car in the on position. When you switch the ignition to the "On" position the Timeset button is no longer lit up. I can get into the engineering menu by using the Ok + 7 + Mute combination, but I see no way to adjust the time zone in either the GPS menu or the system menu. I also am wondering if there is in any sort of function that will be displayed on my instrument cluster. I see nothing at all on that display. Any more information would help. Thanks.
 

·
Registered
2006 C230 W203 SS Red
Joined
·
27 Posts
Discussion Starter · #5 ·
You mean the GPS is working, including the correct maps shown for your area? At least the NTG4 device would not need any time or time zone setting at this point. Are you sure you have set the date correctly, perhaps it is a daylight saving time issue?
What is the NTG4 device and I ran the self tests for the unit in engineering menu and it tested fine. The timeset button is not lit up all. Do you think it needs to go to the dealer? Thanks.
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,429 Posts
What is the NTG4 device and I ran the self tests for the unit in engineering menu and it tested fine. The timeset button is not lit up all. Do you think it needs to go to the dealer? Thanks.
Sorry for some confusion, I thought you were talking about an NTG2.5 device but you actually mean Comand 2.5, an older version. And NTG4 is from a W204 but my intention was to refer to an NTG3 Comand which comes with a W221. :eek: I cannot help with the Comand 2.5 but there should be a lot of owners who should have personal experience with this device.
 

·
Registered
2006 C230 W203 SS Red
Joined
·
27 Posts
Discussion Starter · #7 ·
It is the MB Comand that is made by Alpine and has the DVD and CD Slot behind the screen and it flips down and you insert the discs behind the screen. The timeset button is greyed out when the car is on, but it is off and the key is still in the ignition then the button is lit and wants to me start the car to fix the timeset.
 

·
Registered
2007 C350
Joined
·
144 Posts
It is the MB Comand that is made by Alpine and has the DVD and CD Slot behind the screen and it flips down and you insert the discs behind the screen. The timeset button is greyed out when the car is on, but it is off and the key is still in the ignition then the button is lit and wants to me start the car to fix the timeset.
From your description and since this is a 2006 you are actually talking about the MCS II which is different than COMAND 2.5. I have attached the page out of the owner's manual which might help you. You only have to set the time zone.
 

Attachments

·
Registered
2006 C230 W203 SS Red
Joined
·
27 Posts
Discussion Starter · #9 ·
It is the MCS II. I have tried those instructions and they do not work as the button does not light up when the ignition is turned to the "ON" position. The Comand is from a CLK and it was modified to fit the "C" class. It fits perfectly and everything works fine. The instrument cluster part does not work and the timeset button is not lit up and those are the only things that are not working right now. I hope the dealer can fix this. Anymore information would be greatly appreciated. Thanks.
 

·
Registered
2000 Designo SLK-05 C230WK-05 E320CDi-2010 GLK 350
Joined
·
714 Posts
You set the time using the set up menu in the center of the instrument cluster.
This menu choice needs to be enabled using STAR at the dealer. This will also allow the nav info to be displayed in the cluster as well so you only need to look at the cluster to see the street names, distances and turn prompts without the need to turn your head and look at the nav display. Unlike my VW's, version coding is not a user option.
Where did you mount the GPS antenna? My car used the European retrofit kit so the antenna was mounted behind the instrument cluster looking up through the plastic cover. The Alpine units have many more useful features than the European Nav units.
 
1 - 10 of 10 Posts
Top