Mercedes-Benz Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
3 Posts
This is fantastic thanks!! So you believe the whole problem is just gunk (dirt) getting inside of the unit?

Cheers
I think that the problem is the point of contact, from the end of the mico switch track. is it an electric arc. (small :) ) which over time creates oxidation, which blocks the contact. With the spray and the movements must eliminate this. I would see if revien quickly with time ...
Philippe
 

·
Registered
2006 ML280 CDi
Joined
·
7 Posts
Mercedes W164 ML Heater Control Panel repair

So for those who care or want to do this repair
I ended up removing the climate control unit and taking it apart. no reprogramming needed unless you replace the unit
it was a PITA to take apart though. Mine is a 3 zone so possibly a bit more complicated
something must've been loose in it because I could'nt find any problems on the circuit board, so I put it back together and the problem appears to be fixed
will keep an eye on it for the next few days...
is this thread still going? i have the same problem with my ML280 2006 and i want to fix it.
will try previous page

many thanks
angi
 

·
Registered
Joined
·
2 Posts
Hello,
Excuse me for my bad language, I'm French :grin

I had the same problem on a w164 ML 320 CDI 2006.
My solution:
1 / Remove the case.
2 / open the plastic box.
3 / extract the electronic board of the plastic box.
Be careful, take your time. There are small plastic hooks.
With patience it must come without forcing and without any breaks.
4 / the problem is the two small micro switch.
I have use a spray for contacts that worked very well more small movements to the right and then left to do well penetrate the product.
5 / Reassemble!
I think that the problem is the point of contact, from the end of the mico switch track. is it an electric arc. (small :) ) which over time creates oxidation, which blocks the contact. With the spray and the movements must eliminate this. I would see if revien quickly with time ...
Philippe from France
( Please correct my spelling mistakes....)


Hi guys,

I hope someone can help me. I have exactly the same problem like philippearchi.

I tried to disassemble the climate control but I dont know how to get from there


to there



I dont see any way how to get the unit out of the plastic box. There are no screws, no plastic nipples or something else.
Hope you can help me.

I already tried to contact philippearchi but he didn't answer yet.

Thanks Daniel
 

·
Registered
Joined
·
2 Posts
something went wrong with the pics and I cant edit.

So the question was how to get from there



to there




How can I get the uint out of the plastic box.

Thank you very much.
 

·
Purple Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
21,990 Posts
I don't think philippearchi will be getting back to you about this. He has not logged in for over two years.
 

·
Registered
2002 C230 Sport Coup and 2006 ML350
Joined
·
1,126 Posts
Old thread but timely issue. Been dealing with this for years.
I always had read that a software update might fix it, and i tend to believe it,
as when I replaced to batteries (plural) main and backup battery,
the Climate control worked like new...for a while.

I'd love to get the software update...assuming one has an SDS, how can you get it?
 

·
Registered
CL500 2001 W215
Joined
·
2 Posts
something went wrong with the pics and I cant edit.

So the question was how to get from there



to there




How can I get the uint out of the plastic box.

Thank you very much.

Hi. Thera are 3 soldered points (red). Desolder them. After that put something thin (blue) and just try slowly to take it out. Those blue points are deeper (second board)

Repair of climatronic is easy and without any cost. I belive that theres no need to relpace climtronic steering. I also repair rear SAM units but this is more complicated. Regards

2602649
 

·
Registered
Joined
·
1 Posts
Very appreciative of all the notes in this thread. We just returned from a 1100km trip home, after purchasing a used 2006 ML350, and this issue happened within 6 hours of home. At this point the "Klaudio" work around is working, but I will be looking at using the notes in this thread to remove the unit and see if the "philippearchi" fix will allow for the free spin of the dial.
Cheers
 

·
Registered
Joined
·
1 Posts
Hello...I have a 2003 Mercedes Benz ML350. I had the same problem....UNTIL one day I came across a post in here about squeezing the dial a little bit while slowly turning it back a half of a click...well, that didn't work, BUT I stumbled across a fix that is worthy of a walk around title. Ready for the answer already? I turned the dial to the right a click then half way back the opposite direction (stop b4 it clicks again!) So it's one click to the right and half a click (you won't hear ANY CLICKS OR FEEL ANY-If you do you half to start over the sequence of finding the middle of a click then back and forth (rocking the dial both directions in between a click will move the climate control the fired direction ...but only 1 light at a time per half . So basically if the outside ring had a pointer it would stay within a half a click from its original starting point the whole procedure...just rock dial after that first but b4 the second click. I don't know if it's hard to explain or if y'all are getting it but that works for me.
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,040 Posts
Hello...I have a 2003 Mercedes Benz ML350. I had the same problem....UNTIL one day I came across a post in here about squeezing the dial a little bit while slowly turning it back a half of a click...well, that didn't work, BUT I stumbled across a fix that is worthy of a walk around title. Ready for the answer already? I turned the dial to the right a click then half way back the opposite direction (stop b4 it clicks again!) So it's one click to the right and half a click (you won't hear ANY CLICKS OR FEEL ANY-If you do you half to start over the sequence of finding the middle of a click then back and forth (rocking the dial both directions in between a click will move the climate control the fired direction ...but only 1 light at a time per half . So basically if the outside ring had a pointer it would stay within a half a click from its original starting point the whole procedure...just rock dial after that first but b4 the second click. I don't know if it's hard to explain or if y'all are getting it but that works for me.

You are on the wrong forum.

 
21 - 31 of 31 Posts
Top