Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Smartkey wont turn from 0 position while in ignition. FOB and spare FOB light up when I press unlock button but vehicle doesn't respond. Vehicle still has power for some functions (moving seats, hazard lights, interior lighting) but these work without the key in the ignition. Have changed battery but did not fix the problem. Problem occurred after attempting to start the vehicle in extremely cold weather with a completely dead battery. Have tried wiping off debris from inside ignition. Is it possible that the dead battery somehow erased my vehicle's memory of the key? Next step will be to change the fuses? Any ideas what the cause could be? Which fuses to change? If that doesn't work what other alternatives are there?
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,044 Posts
How did you come to the conclusion that you had a dead battery?

For starters, check fuse #14 in Cockpit Fuse Box. Other than that, you will need a scanner to read codes in all modules.

 

Attachments

·
Registered
Mercedes ML350 4Matic 2006 - Mercedes C230 Kompressor 2006
Joined
·
1 Posts
I have the same problem. Recently I bought another ML350 to repair and leave the city on weekends.
The key does not turn in any position. I removed the rear SAM finding corrosion, the key does not open or close the doors. I will try to repair the circuit damaged by corrosion to recover the locking system with the key.
Next step I will see the status of the front SAM and the Central Gateway to eliminate all possible electronic failures.
Fuse 14 has already been checked, as all the fuses in the car and all in good condition.
I think I'm going the right way, what I still don't get is the original auxiliary battery which is not installed, the key batteries are new and the car battery too.
I will try to make the key work so I can perform a sacanner with the SD.

Regards
Luis
 

·
Registered
Joined
·
4 Posts
I have the same problem. Recently I bought another ML350 to repair and leave the city on weekends.
The key does not turn in any position. I removed the rear SAM finding corrosion, the key does not open or close the doors. I will try to repair the circuit damaged by corrosion to recover the locking system with the key.
Next step I will see the status of the front SAM and the Central Gateway to eliminate all possible electronic failures.
Fuse 14 has already been checked, as all the fuses in the car and all in good condition.
I think I'm going the right way, what I still don't get is the original auxiliary battery which is not installed, the key batteries are new and the car battery too.
I will try to make the key work so I can perform a sacanner with the SD.

Regards
Luis
Hi Did you find a solution this just happened with my 2006 ML 350 I’m waiting for a tow truck any advice
 

·
Registered
Joined
·
4 Posts
I have the same problem. Recently I bought another ML350 to repair and leave the city on weekends.
The key does not turn in any position. I removed the rear SAM finding corrosion, the key does not open or close the doors. I will try to repair the circuit damaged by corrosion to recover the locking system with the key.
Next step I will see the status of the front SAM and the Central Gateway to eliminate all possible electronic failures.
Fuse 14 has already been checked, as all the fuses in the car and all in good condition.
I think I'm going the right way, what I still don't get is the original auxiliary battery which is not installed, the key batteries are new and the car battery too.
I will try to make the key work so I can perform a sacanner with the SD.

Regards
Luis
Hi Did you find a solution this just happened with my 2006 ML 350 I’m waiting for a tow truck any advice
 

·
Registered
Joined
·
4 Posts
How did you come to the conclusion that you had a dead battery?

For starters, check fuse #14 in Cockpit Fuse Box. Other than that, you will need a scanner to read codes in all modules.

Hi Did you find a solution this just happened with my 2006 ML 350 I’m waiting for a tow truck any advice
 

·
Registered
Joined
·
4 Posts
Smartkey wont turn from 0 position while in ignition. FOB and spare FOB light up when I press unlock button but vehicle doesn't respond. Vehicle still has power for some functions (moving seats, hazard lights, interior lighting) but these work without the key in the ignition. Have changed battery but did not fix the problem. Problem occurred after attempting to start the vehicle in extremely cold weather with a completely dead battery. Have tried wiping off debris from inside ignition. Is it possible that the dead battery somehow erased my vehicle's memory of the key? Next step will be to change the fuses? Any ideas what the cause could be? Which fuses to change? If that doesn't work what other alternatives are there?
Hi Did you find a solution this just happened with my 2006 ML 350 I’m waiting for a tow truck any advice
 
1 - 8 of 8 Posts
Top