Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
W211
Joined
·
3 Posts
Discussion Starter #1
I desperately need some help and info from all of you. I'm facing a problem with NO SOUND after i replaced my Audio 20-CD with 2009 Mercedes Benz W211 E350 E550 E63 HDD NTG2.5 Navigation Comand 6 DVD Changer.

So far that I concerned, the NTG2.5 that i bought has been installed with car that has HK amplifier in it WHICH i haven't got any HK system in my car.

I already bought All the harness kit in order to convert wiring system:
1. CABLE RETROFIT GPS MERCEDES W211 W219 AUDIO 20 COMAND NTG2.5
2. ADAPTADOR ANTENA FAKRA RETROFIT
3. MICROFONO MERCEDES COMAND NTG 2.5 MICROPHONE RETROFIT
4. ANTENA BLUETOOTH MERCEDES COMAND NTG 2.5 ANTENNE
5. GPS ANTENNA

Everything is perfect, the cluster instruments also detected/read the NTG2.5 unit but SOMEHOW there is NO SOUND comes out AFTER ALL.

What should I do PLEASE?
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,426 Posts
Must be a version coding issue, your new COMAND is configured for the external amplifier and you should reconfigure the MOST ring to no devices present.
 

·
Registered
W211
Joined
·
3 Posts
Discussion Starter #3
Must be a version coding issue, your new COMAND is configured for the external amplifier and you should reconfigure the MOST ring to no devices present.
Therefore just coding it and the problem will be solved? can official MB dealer do that coding thing? Thanks for the info
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,426 Posts
can official MB dealer do that coding thing?
They should be able to do it but it isn't always exactly straightforward to reach the control unit from SDS. You should find instructions from some NTG2.5 retrofit threads.
 

·
Registered
W211
Joined
·
3 Posts
Discussion Starter #5
They should be able to do it but it isn't always exactly straightforward to reach the control unit from SDS. You should find instructions from some NTG2.5 retrofit threads.
Thanks for the guidance Diesel Benz. i'll look the thread regarding NTG2.5 retrofit.

Cheers
 

·
Registered
2004 E55
Joined
·
624 Posts
Any outcome on this? I'm having the same issue, no sound. My car had hk on my old ntg1 and upgraded to ntg2.5 with hk and no sound, any tricks or something I'm missing?
 

·
Registered
Joined
·
6 Posts
Any outcome on this? I'm having the same issue, no sound. My car had hk on my old ntg1 and upgraded to ntg2.5 with hk and no sound, any tricks or something I'm missing?
If you have HK that mean there is an amplifier, just go to hidden setting and turn external Amplifier ON.
 
1 - 8 of 8 Posts
Top