Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi All

My fan is not spinning, we did all the normal checks and then moved it. The motor is working, so must be the control unit. Has anyone has any luck replacing just the control until? or the other option is getting one of these https://www.ebay.com.au/itm/263290633978?ul_noapp=true. Which is meant to be compatible and comes with a year warranty..The wreckers fans are the same price, but no warranty, trying to work out the cheapest and best option.

Thanks in advance!
 

·
Registered
Joined
·
6,617 Posts
A 50 amp relay and toggle switch will get you by until you can come up with something more reasonable priced..
Relay will not do it. This is brushless motor that needs controller to send pulses in sync with fan speed.

There is report in W164 forum about successful repair.
 

·
Registered
Joined
·
269 Posts
Relay will not do it. This is brushless motor that needs controller to send pulses in sync with fan speed.

There is report in W164 forum about successful repair.
Witek.. I believe you.. DC servo drive, .. Makes sense.. What I want to know is how one can check a servo drive motor without a working drive.. which genaaswell stated.. "My fan is not spinning, we did all the normal checks and then moved it. The motor is working, so must be the control unit."
Now knowing it's a DC servo.. I would be guessing "seized bearings"...
 

·
Registered
Joined
·
6,617 Posts
Witek.. I believe you.. DC servo drive, .. Makes sense.. What I want to know is how one can check a servo drive motor without a working drive.. which genaaswell stated.. "My fan is not spinning, we did all the normal checks and then moved it. The motor is working, so must be the control unit."
Now knowing it's a DC servo.. I would be guessing "seized bearings"...
We need to hear from OP to go any further with this. ;)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Thanks for replies, sorry I normally get an email letting me know there is a new post, but I haven't had any.. Anyway just to clarify, we gave the fan direct power when still in the car, but nothing, then we removed from the car and took to a mechanic and he said the motor is working fine, so must be the control unit...there is a burnt smell coming from control unit, so reckon that's the culprit, thanks for the link on the guy who fixed his, we are going to give it a try.
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
3 Participants
genaashwell
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top