Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
BenzWorld Post Whore
10 E350 4MATIC
Joined
·
3,832 Posts
At about 60C, I start to feel my heater working. Even at normal temp, your heater aint working?

FWIW, on my ML350 this is the normal operating temp:

<img src="http://babenj.tzo.com:6971/s4toml/images/ML350_010503/DSCN0410.JPG">
 

·
Registered
1999 Kleemann ML43K
Joined
·
1,390 Posts
I have a 99 that gets hot as hell and always has

pointman - 3/4/2005 3:41 PM

yeah, i have no heat what so ever. dealer here i come.
Let us know what the issue is to look out for...
 

·
Registered
Mercedes "M32"
Joined
·
961 Posts
RE: I have a 99 that gets hot as hell and always has

LOCHS 2 - 3/4/2005 7:22 PM

pointman - 3/4/2005 3:41 PM

yeah, i have no heat what so ever. dealer here i come.
Let us know what the issue is to look out for...
I think your blower helps with the heater ... [:p]
 

·
Registered
1999 Kleemann ML43K
Joined
·
1,390 Posts
Good point

MLOffRoad - 3/4/2005 6:25 PM

LOCHS 2 - 3/4/2005 7:22 PM

pointman - 3/4/2005 3:41 PM

yeah, i have no heat what so ever. dealer here i come.
Let us know what the issue is to look out for...
I think your blower helps with the heater ... [:p]
It does get much hotter under the hood and it tends to creep into the cabin at will. I have to turn it down almost to the white to make it comfortable enough after a half hour or so. And I never have to turn it up to the three or four level of the fan. Part of that is because I go from the garage to an underground parking garage at work. She only sees snow while I'm driving.
 
1 - 7 of 7 Posts
Top