Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Guys

I have 2004 clk 55 amg w209. Since I purchased it I haven't driven much. I have had issues with the cooling system from the onset. It has 135000km. So I decided to put a new radiator, water bottle and cap, new coolant and flush the system. Drove for a few days only for the water pipe to burst. (from the radiator to the block to the coolant bottle). Changed the water pipe. Now the pipe popped out of the radiator where the fast release clip is. I've refilled the water but am almost sure the problem is going to persist.

Any ideas how I can resolve?

Over and above the issue, how do I bleed a CLK 55 AMG W209 radiator?

Thanks Guys.
 

·
Registered
MY05 CLK55 AMG ,CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Joined
·
1,911 Posts
Hi ,
Not sure why the first hose would burst ,,but the new one probably came loose because the clip was not in place properly.
Did you fill the system with 5.25 L of MB 325.0 spec blue concentrated coolant and then top up with pure distilled or deionised water ?
There should be no need to bleed the system ,, just idle the car up to temp and have the heater on high temp so the coolant circulates...it should self bleed ,,,just keep topping up the tank / reservoir / bottle as the level goes down , maybe give the top hose a squeeze every minute or so.

What does the coolant temp do when driving ?,,it should go up to about 85 to 90 within about 5 minutes and then stay there.
If you still have trouble maybe you need to replace the thermostat...
 
1 - 2 of 2 Posts
Top