Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
2003 C32 AMG
Joined
·
12 Posts
Discussion Starter #1 (Edited)
URGENT! 2003 C32 Need help, cylinder 3 misfire

So here is the story.......Last night i valley-ed my car at a resteraunt, when I came out he opened the door for me and I tipped him. He had parked another car in front of me so i had to back up at and angle to allow myself proper clearance from the car in front of me. well what I didn't know was that the curb extended out behind my car and there was a fire hydrant there ( I know this is not easy to visualize) you know where this is going, so I hit the hydrant it cracked my taillight and then deeply crinkled the passenger rear quarter panel almost to the gas cap. I drove it home and when i went to start it this morning the CEL was on and it was idling very poorly. immediately drove it to the mercedes dealer ship, they have not completed diagnostics test but they told me I have a misfire in cyllinder 3. So my humble questions are as follows
1. could I have done enough damage to my car that the fuel line was damaged and maybe water/air got in and is causing the misfire?
2. what else could the problem be? I got the car 2 weeks ago, had to top off coolant and about 100 miles later coolant is low again.
Could it just be plugs leads etc?

Thanks for you help
 

·
Registered
2003 C32 AMG
Joined
·
12 Posts
Discussion Starter #2
what I was trying to say about the coolant

could it be that coolant is leaking into cylinder 3? maybe head gasket?
 

·
Registered
2003 C32 AMG
Joined
·
12 Posts
Discussion Starter #3
Wow

This is amazing, I have been through every post for "idling, misfiring," etc on this site for my car (c32) or similar. and this problem is like the super sneaky problem that no one seems to know the answer to. Further more anyone who ever posts on this subject seems to NEVER get to the bottom of it! They just disappear, I think its a conspiracy and anyone with this problem is actually killed.

Is there any mercedes tech out there that knows his sh*t when it comes to W203 C32? I am looking for anyone who can help me not spend thousands in diagnostics, I will pay for advice that helps me solve my problem


PLEASE SOMEONE:bowdown:
 

·
Registered
2004 c230 Sedan
Joined
·
10 Posts
I have a 2004 c230... same issue with getting the same weird kinda idling... specially when u start the car and turn on the a/c at the same time....
 

·
Registered
2003 C32 AMG
Joined
·
12 Posts
Discussion Starter #7
More insight

It seems that fccthawk is correct. I have been losing coolant pretty fast lately so I brought it to the shop. seems the intake is covered with coolant gunk. This explains a lot.
 

·
Registered
2003 C32 AMG
Joined
·
12 Posts
Discussion Starter #9
plenum

This is the thing that covers the intake on your engine, they will say AMG on them, they are on the sides of the engine.
 
1 - 12 of 12 Posts
Top