Mercedes-Benz Forum banner
1 - 7 of 7 Posts

·
Registered
2012 CLS550 4matic / 2009 GL550 4matic / 2006 ML350 4matic / 2005 E320 4matic
Joined
·
146 Posts
Discussion Starter · #1 ·
Does anyone out there know where I can find a good DIY for replacing the starter in a 2003 C230 (non-4matic) kompressor? Are there any side issues that tie into replacing this part that I should be aware of before taking on the task? Degree of difficulty?

Any assistance that can be given is greatly appreciated, thank you!
 

·
Registered
C230K Sport Sedan
Joined
·
5,368 Posts
Not a common problem so you may not see much about it here. You can always subscribe to alldatadiy.com and they provide all the info you ask for. Typically a starter is not difficult to replace, disconnect the wiring, unbolt the 2 bolts holding it in and pull it out. But since I've never specifically done on a C, I can't tell you if there's anything special. It's not likely going to be in a friendly spot to get to so you may bust some knuckles but that's part of the fun.

But here's the deal. I sense that you are not mechanic, otherwise you would have done it already. With tax, this is a $600 part but they sell many of the components seperately like the armature, solenoid and brushes, which are very cheap in comparison, like $30 for brushes from the dealer. You maybe able to get a reman unit for half that price. So don't know what your motivation for doing it youself is, because if you don't know what you are doing, at best, you will be out the money for the entire starter. But if you took it to someone that is a good mechanic, he can pull the starter, look to see what's causing to not work and just replace the part that's needed. I would remove it myself, take it to a place that works only on alternators and starters and have them look at it, test it and replace the worn parts and put it back in. Just my 2 cents.

What is it doing? Spinning freely without engaging? Not spinning at all? Spinning too slow to start car? Making grinding sounds?
 

·
Registered
2002 C230 Sport Coup and 2006 ML350
Joined
·
1,138 Posts
I could use a little help here.
Pulling the starter out was a bear, and I
am quite certain there is a trick that involves pulling the steering column out
of the way.
Putting it back is going to be worse if I don't have any room to move.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
24,962 Posts
Yes, on the C230 Kompressor, you do have to disconnect the steering column linkage to the rack. According to WIS, you also have to disconnect one of the A/C lines that runs behind the starter.
 

·
Registered
2002 C230 Sport Coup and 2006 ML350
Joined
·
1,138 Posts
Yes, on the C230 Kompressor, you do have to disconnect the steering column linkage to the rack. According to WIS, you also have to disconnect one of the A/C lines that runs behind the starter.

Wow, thanks for responding. I got the starter rebuilt today, and
I pulled out the wheel well lining but, in the end,
somehow that piece of steering column needs to come out, but I don't see how.

I have the DVD, and even tried alldatadiy.com but what a waste of money.
Neither have instruction to pull the starter.

Can you please email me some printouts from the WIS?
I'll PM you, thanks!
I'd like to get this bolted back up tomorrow, Thurs, if possible.

BTW getting it out, I had to disconnect the selenoid and it was a real mess,
very obviously wrong.
BTW I have a 2002 w/ 2.3L
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
24,962 Posts
Sorry, I've been out of town and don't have access to WIS right now. You shouldn't have to disconnect the entire steering column - just the linkage at the rack. Also, I'll bet you won't have to remove that A/C hose - you may be able to loosen some of the clamps securing it to the engine compartment and gently move it enough to gain the clearance you need. Once I get back (end of next week), I'll see if I can get some diagrams posted.
 

·
Registered
2002 C230 Sport Coup and 2006 ML350
Joined
·
1,138 Posts
It's back in, I'll post details later.
You need about 3.5" of socket extensions, what a b__tch.
I screwed up on reattaching the support bracket, will do that tonight
and then she'll be running, I hope.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top