Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
2003 A190 full auto - petrol
Joined
·
1 Posts
Discussion Starter #1
Can any one assist? I have a 2003 automatic (petrol) A190. Its shows an engine management light that cannot be cleared and occasionally slips into F (transmission fault).
OBD pulls a P0715 code only which I see is: Input/Turbine Speed Sensor Circuit Malfunction.
The car drives fine - does not go into limp mode and the auto box selects up and down fine.
I have a Haynes manual which does not assist with this issue or location of a turbine speed sensor nor is the circuit covered :/
My question is where is the input speed sensor located? so I can start checking from there.
I see the output sensor is in the valve chest (though input is elsewhere).
 

·
Registered
Vito 115cdi 2005
Joined
·
100 Posts
I am not 100% sure about yours but on mine (2007 A170) both sensors are on the same plate bolted to the valve chest
 

·
Registered
Joined
·
7 Posts
Can any one assist? I have a 2003 automatic (petrol) A190. Its shows an engine management light that cannot be cleared and occasionally slips into F (transmission fault).
OBD pulls a P0715 code only which I see is: Input/Turbine Speed Sensor Circuit Malfunction.
The car drives fine - does not go into limp mode and the auto box selects up and down fine.
I have a Haynes manual which does not assist with this issue or location of a turbine speed sensor nor is the circuit covered :/
My question is where is the input speed sensor located? so I can start checking from there.
I see the output sensor is in the valve chest (though input is elsewhere).
 

·
Registered
Joined
·
7 Posts
Hi , you're right , got the same problem Input/turbine speed sensor is located at front between engine and transmission A190 W168 2000 up . bolted with 1 bolt works as crankshaft speed sensor.
 

·
Registered
Joined
·
7 Posts
Hi , you're right , got the same problem Input/turbine speed sensor is located at front between engine and transmission A190 W168 2000 up . bolted with 1 bolt works as crankshaft speed sensor.
Have check it camshaft position sensor ? My was faulty
 

·
W168, W169 Moderator
A180 CVT, A170, A190, B200
Joined
·
466 Posts
occasionally slips into F (transmission fault).
OBD pulls a P0715 code only which I see is: Input/Turbine Speed Sensor Circuit Malfunction.
The car drives fine - does not go into limp mode and the auto box selects up and down fine.
Hi, P0715 is a generic code and it might cause confusion sometimes. If you use a more specialised scanner you might get fault code P1850, not OBD and that matches your description.
Turbine speed sensor is built in with the FTC, transmission control unit.
The sensor between the engine and gearbox is crankshaft position sensor.
 

·
Registered
Joined
·
7 Posts
Turbine output speed sensor is build in the TCM I know , Mercedes w168 A190 before I got into F and limp mode check engine blinks few times CPS faulty .
 

·
Registered
Joined
·
7 Posts
Input/Turbine Speed Sensor Circuit Malfunction Fault code 0715 is not a transmission fault code, it is normally a CAN bus fault, this can be caused by one of several reasons, for example if the codes are only stored this can be caused by a flat battery at some stage in the past, from having the ignition turned on while the transmission module is disconnected or another component on the CAN bus is disconnected, wiring issue or component fault or one of several other reasons,
 
1 - 10 of 10 Posts
Top