Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have had all the warning lights come on sporadically all pointing towards the abs module. The issue im having is when i go to apply the brakes, even a slight tap makes the brakes lock and the car screeches to a halt. Its very scary even happens when ive gone over 50mph. It doesnt do it all the time but does happen here and there so im not driving it. I drive for a living so i took the car into a friends mechanic. He told me he replaced the angle sensor and the clock spring. But the issue hasnt changed or gotten better. Other forums and posts have pointed towards a bad abs module alltogether but said it was expensive.

Is there a way to just disable the whole abs module? Or a way to fix this vehicle instead of paying out the ass for it?? The $600 repair i just got done obviously didnt correct the problem at all. Thank you.
 

·
Registered
Joined
·
6,656 Posts
I have had all the warning lights come on sporadically all pointing towards the abs module. The issue im having is when i go to apply the brakes, even a slight tap makes the brakes lock and the car screeches to a halt. Its very scary even happens when ive gone over 50mph. It doesnt do it all the time but does happen here and there so im not driving it. I drive for a living so i took the car into a friends mechanic. He told me he replaced the angle sensor and the clock spring. But the issue hasnt changed or gotten better. Other forums and posts have pointed towards a bad abs module alltogether but said it was expensive.

Is there a way to just disable the whole abs module? Or a way to fix this vehicle instead of paying out the ass for it?? The $600 repair i just got done obviously didnt correct the problem at all. Thank you.

Without specific codes from traction system there is no way to determine what is going on.

In a meantime remove relay K25 for ABS pump.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Get the car scanned with a pro level scanner & post the codes here.

Also update your location & vehicle details on User CP.

Let's start from there.
I am trying to figure out how to get to the mechanic (mercedes mechanic) and will post.
 

·
Registered
Joined
·
864 Posts
Remove K25 relay to help your issue...

I am trying to figure out how to get to the mechanic (mercedes mechanic) and will post.
Brian:

My w163 did a similar weird thing, besides displaying those warning lights, it would automatically apply a single wheel brake full force, scaring the tar out of me.

Thankfully it was always at less than 20 mph, and just one wheel. But boy oh boy just like Ghost Braking.

My solution was just as Witek said, open underhood relay box, locate relay "K25" and remove it from socket.

This disables ABS pump which SHOULD stop your sudden full force brake application.

Doing this stopped my 'auto braking on 1 wheel'. My situation happened 500 miles from home !

I traced it down via scanning codes to a defective Yaw Sensor (aka Turn Rate Sensor).

Maybe this is your issue, only a scan will tell.

I only found a Yaw Sensor on Ebay, fwiw. MB doesn't offer them anymore but used market supplies them in decent #'s.

Hope this helps.

David in East Texas
 
1 - 5 of 5 Posts
Top