Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
2002 E320 4MATIC, 2009 E-350 4MATIC
Joined
·
1 Posts
Discussion Starter #1
The trunk release swith on the console stopped working. Even the light on it does not light up when the switch is pull. The trunk opens fine with the remote.

Any Ideas?

Thanks
Tony
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
Do you see a way to clean the switch? It might be more serious (new switch) but cleaning it is worth a shot.

BTW, please come join us on the W210 forum. You can find us in the sedans section. Welcome, and good luck.
 

·
Registered
2012 E350 :-) 2002 E320 (sold)
Joined
·
432 Posts
The trunk release swith on the console stopped working. Even the light on it does not light up when the switch is pull. The trunk opens fine with the remote.

Any Ideas?

Thanks
Tony
My 2002 E320 did the same thing. The key fob worked and I could push in the trunk lock and it would open. When I did that, the red light on the console trunk button lit. I tried switching the hoses on the PSE pump under the rear seat and that did not help. My guess is that the problem was the switch under the console. I never fixed it. I think the switch under the console was about $400 or so. It wasn't worth it to me.
Do a search under the W210 forum and see what others have written.
I sold the car last week. The new 2012 switch works fine. :)
 

·
Registered
99 E430, 01 E430 Sport, 00 SL500
Joined
·
3,266 Posts
I had a crack on that switch before. You think you pulled it but you pulled only the top cover, the actual part to activate stayed. That's why there's no action, no light. Lower your head to see up close at the bottom of the switch. You may see something while lifting it up gently. I don't recall if the wood panel had to be removed to see the crack. it's been years ago.
 
1 - 4 of 4 Posts
Top