Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
my problems started when my check engine light came on , the codes read p0175 p0700, so i changed my conductor plate and plug , then i took the car to the shop to erase the codes and get the car out of limp mode, my problem is the car does not shift well through 1st and 2nd gear, and the code p0175 pops up , did anyone have this problem before ? could i of ruined the car when it was in limp mode? can someone please help? thanks
 

·
Registered
Joined
·
163 Posts
was the connector leaking when you removed it? the oil could have traveled up the wiring harness and into the transmission control module. it is not uncommon for this to happen.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
was the connector leaking when you removed it? the oil could have traveled up the wiring harness and into the transmission control module. it is not uncommon for this to happen.
when you say control module, are you talking about the conductor plate? because i changed the conductor plate ,
 

·
Registered
2000 and 2003 W220 S500
Joined
·
930 Posts
Please check to see if its the Gear Select Module, if you see ESP not available, it's a fair indication of that or the Transmission Control Module being bad.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Please check to see if its the Gear Select Module, if you see ESP not available, it's a fair indication of that or the Transmission Control Module being bad.
when you say control module are you talking about the conductor plate??
 

·
Registered
2000 S430 156k (11/12)
Joined
·
507 Posts
Below are what the codes mean
DTC P0700 Transmission Control System Malfunction
DTC P0175 Fuel Trim System Rich Bank 2
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Below are what the codes mean
DTC P0700 Transmission Control System Malfunction
DTC P0175 Fuel Trim System Rich Bank 2
yes these are the two codes that pop back up after the conductor plate and plug were changed , do you think it could be a bad solenoid? or i just need a new value body?
 

·
Outstanding Contributor
2002 S430
Joined
·
1,927 Posts
YES and YES ,but like my other post to you check it out first don't just go changing parts unless needed.

Dean
 
1 - 13 of 13 Posts
Top