Mercedes-Benz Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello,
I know this topic has been talked about a million times on the board but I couldn't find anything like my situation.

I have a 2001 s430 and when I press the rise button it says vehicle rising but nothing happens. It stays on the dash until I press the button again to turn it off. You would think that it's the pump but I hear the pump run when I first turn on the car. But the pump doesn't turn on when I press the rise button. i don't have any warning lights or anything on the dash. The car seems a bit low but nothing too drastic like I've heard.

Any ideas would help,

Thanks,

Adham
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,978 Posts
Welcome to the forum.

This problem has been written up recently, a matter of days ago; I don't know that it has a final solution yet; the contributors thought it was a failing pump or valve block. Because it isn't a completed issue, I haven't bookmarked it - but you should be able to find it fairly easily.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Welcome to the forum.

This problem has been written up recently, a matter of days ago; I don't know that it has a final solution yet; the contributors thought it was a failing pump or valve block. Because it isn't a completed issue, I haven't bookmarked it - but you should be able to find it fairly easily.
Thanks for the quick reply.
From what I understand, he had the car in the shop for 9 days till he mentioned the relay to the mechanic and all of a sudden the car was fixed.

Should I start with the relay?
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
If the pump runs on first start up, then the relay is ok. you may have a wiring problem.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
If the pump runs on first start up, then the relay is ok. you may have a wiring problem.
ok just went out and checked the car some more,

when I first start the car, the pump starts to run for a minute or two but nothing happens. The car isn't going up at all. It is sitting a little low and it stays that way even after the pump stops running. The tire is about even with the fender.
Also, still nothing happens when I press the raise button, pump doesn't even turn on.

Hope this gets me some more help

Thanks again.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Sounds like the car is low. The pump may not be running long enough to have any effect. Try another relay first.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Sounds like the car is low. The pump may not be running long enough to have any effect. Try another relay first.
It ran for a good 3 minutes and nothing happened. Also it came back on with the car still in park in the driveway and nothing changed.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
It ran for a good 3 minutes and nothing happened. Also it came back on with the car still in park in the driveway and nothing changed.
In this case there appears to be a leak between the pump and valve body, the valve block sits on top of the pump so check the pipe that runs between the two.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
In this case there appears to be a leak between the pump and valve body, the valve block sits on top of the pump so check the pipe that runs between the two.
yeah I was thinking something like that. I will definitely check it out. What does the valve body do?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
but does this relate to the pump not turning on when I press the raise button? or is that an issue on its own?
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
yeah I was thinking something like that. I will definitely check it out. What does the valve body do?
The valve body directs the flow of air to the required locations including the reservoir.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
but does this relate to the pump not turning on when I press the raise button? or is that an issue on its own?
We will know the answer to this when the first problem is fixed and the car moves to standard ride height.
 

·
Registered
W210 E290td(sold) W210 E280(sold) W220 S320(sold)
Joined
·
4 Posts
hi there, when the pump is functioning that doens't mean you'll have enough pressure.
you can check that with a stardiagnose or carsoft software.
 

·
Registered
Joined
·
5 Posts
When I press the rise button I don't hear the pump turn on right away. Is it suppose to? I kept the button on and in about 1 minute or so the pump kicked in, is that normal?

I know I have a leak in the caps so I'm going to try the epoxy fix. Would a leak prevent one corner of the car to not rise as high as the others? My front passenger seems to always be about 1/2" lower than the drivers side. The drivers side cap is the one with the leak.
 

·
Registered
W210 E290td(sold) W210 E280(sold) W220 S320(sold)
Joined
·
4 Posts
Hi there,
When i changed my pump and airmatic relay (hella) the car was rising faster as i hit the button. You must checke your valve block for leaks and working correctly and the pump for its pressure.
Instead of using the epoxy you can also think about a remanufactered strut(s) by Arnotts, they give a life time warranty.
The top of the strut is not the only problem, it is also possible that the innerside of the strut has a leak. (ore comes to leak)
Maybe you have the possibility to drive to a dealer or indy for a computer diagnostic.
They can check a lot of airmatic issues in a few minutes.
 

·
Registered
2012 S550 Bi-Turbo 4Matic
Joined
·
303 Posts
i have discovered an easy way to tell if the car rises or not when you press the airmatic button.

Instead of watching the emblem against your garage door or wall, just open the door and put your left foot flat on the ground and then hit the button.

You'll notice right away if the cars lowers or raises.
 
1 - 20 of 32 Posts
Top