Mercedes-Benz Forum banner

1 - 20 of 20 Posts

Registered
2001 W220 S320 CDi
Joined
30 Posts
Discussion Starter #1
The car was in limp mode due to swirl flap motor being broken.

In limp mode the engine runs sweet as but obviously has no turbo power.

Now it's out of limp mode, at tickover particularly it runs very rough like on 5 cylinder, or possibly 4.

Changed fuel filter and no better, sometimes it doesn't do this and runs fine, but not for long.

If I give it gas, the problem goes away..

It's been on Star and no codes, all injectors pass the test etc.

Any ideas please?
 

W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
5,880 Posts
Hi,

What exactly have you done to get it "out of limp mode".

I also suggest a proper Compression Test, not an Electronic one ;)

SDS is needed to see all, cheaper machines don't see the half of what is going on and can't run the tests ;)

HTH,
 

Registered
2001 W220 S320 CDi
Joined
30 Posts
Discussion Starter #3
Sorry, I was a little vague there... I replaced the solenoid motor for the swirl flaps!

The star system was a proper MB one BTW.

If it was compression, surely it would do the same in limp mode?

Very strange problem.
 

Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
1,311 Posts
Have you done a diesel injector leak off test? That is important to do now and inexpensive
 

Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
1,311 Posts
I don't think he has, what exactly is required to do a test.,
Google is your friend here. This is one video on you tube as an example. There are other good videos on the subject too


Buy a ebay leak off kit. Easier and better than trying to knock up a home brew kit. I use mine once or twice a year and it's really handy to just grab the case and get started. It also has adapters to connect onto all MB models
 

W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
5,880 Posts
Hi,

If the guy who did the Flap motor is the same one with Genuine SDS then he likely knows what he's doing, but do check SDS as there is a possibility the unit needs a teach in procedure before it will work correctly, so if it is holding the flaps open as a default it would cause bad running at low RPM but go OK on higher RPM ;0

HTH,
 

Registered
W123 1985 T-model M110
Joined
23 Posts
May be over boost? Vacuum solenoid blocked or pass vacuum at idle,and low rpm.
Also swirls , can block some windows at manifold. The motor driver of swirls had reason to break.
Overboost also can be if broken VGT flaps in turbo, broken/or burned throw


袨褌锌褉邪胁谢械薪芯 褋 屑芯械谐芯 GM 5 Plus 褔械褉械蟹 Tapatalk
 

Registered
2001 W220 S320 CDi
Joined
30 Posts
Discussion Starter #10
Hi, they tested them and all was fine. I removed and cleaned the egr valve and inlet manifold, but the solenoid was knackered trying to move all coked up crap.

The really odd thing is if I removed the plug for the MAF sensor, it doesn't go into limp mode and I understand it should.

I really need someone in London that knows these cars....
 

W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
5,880 Posts
A lot of yee ha's in England, hard to sort the wheat from chaff ;)

Bring it to NW Scotland and B&B a couple of days, enjoy the rain and scenery, fine wine and locally caught seafood etc ;)
 

W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
5,880 Posts
Un plugging MAF is telling me that you may have an Air Leak / Incongruence, by unplugging it the Car will run on a basic Air Table, so will not know it has an Air Leak (that is put in very basic language btw, just to make it easy to understand, before someone jumps on me ;)

Has the Car actually been on SDS ??

(Read my Signature) other Machines even expensive ones like 拢1000 upwards DO NOT SEE AND DO EVERYTHING on MB's ;)

Ahhh OK I see in your OP that it went on SDS but depends on operator, if I got no Codes I would next do all the tests, can sometimes take a few hours, problems like this are not always just a "Code Read"

HTH,
 

Registered
2001 W220 S320 CDi
Joined
30 Posts
Discussion Starter #13
Hi, yes it's been on proper SDS at a specialist and showed no codes once motor changed.
 

W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
5,880 Posts
IV40 , right by Eilean Donan Castle, about 600 miles from London lol, I was joking sort of ;)
 

Registered
2001 W220 S320 CDi
Joined
30 Posts
Discussion Starter #16
Crikey! Bit far :)

Had a bit of a thought, when in limp mode it runs perfect so it must be enabling something in normal mode that isn't available in limp mode.

The swirl flap motor (and bunged inlet man) caused the limp mode.

It does feel very much like fuel starvation....
 

W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
5,880 Posts
I really don't understand that statement ................

When any ECU has set a Limp Mode it does not run perfect .............
They run at restricted performance, eg Power and sometimes RPM fault dependent.

What exactly are you trying to tell me, are you saying it runs better when you unplug the MAF ?

HTH,
 

Registered
2001 W220 S320 CDi
Joined
30 Posts
Discussion Starter #18
Hi, what I mean by running perfect is it ticks over with no hiccupping and missing in limp mode.

It doesn't go into limp mode now I have had the flap motor changed and runs terribly at tickover.

The odd thing is it doesn't go into limp mode when I unplug the maf sensor as I believe it should and just continues to run very roughly.
 

W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
5,880 Posts
This Car needs SDS and an Expert, CDI's are easy to fix with SDS when you fully understand them.

I have had loads through my Workshops, all our tight fisted locals will not buy Petrol MB's ;)
 

Registered
2001 W220 S320 CDi
Joined
30 Posts
Discussion Starter #20
I agree. I don't think the guy using SDS knew that much.

A trip to Scotland looks quite enticing to be honest....

I do need to get away for a few days
 
1 - 20 of 20 Posts
Top