Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey all. New to posting. Currently trying to solve a small tran. leak thats not from tramsmission. Research reveals that it could be from the A/T plug adapter. Found that ($9.95) but does not come with the red O-ring. Any info would br appreciated.
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
The latest part comes with an updated o-ring already attached. You might spend a little more but buy one from a MB dealer. When you get a chance please join us on the W210 forum. You'll see a lot of discussion on this common issue.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for your rapid reply. I'm looking forward to the massive amts. of info and $ saving advice.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Thanks for your rapid reply. I'm looking forward to the massive amts. of info and $ saving advice.
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

At the bottom of the page you will find forum jump, click on this and view all the available sub forums.

For FAQ see the Benzworld help section here:
BenzWorld Help - Benzworld.org - Mercedes-Benz Discussion Forum

Regards
 
1 - 4 of 4 Posts
Top