Mercedes-Benz Forum banner

41 - 52 of 52 Posts

·
Registered
Joined
·
2,224 Posts
Is any one has reset displace:"Oil change past due" etc.. on cluster message after DIY oil change ? and how to ?.. very much appreciated.

GOT IT..
 

·
Registered
Joined
·
109 Posts
Today I decided to try a topside oil change where you siphon out the old oil with an extractor (mityvac). This on a USA 2001 C240 with a M112 V6. Of course this year/model doesn't have a dipstick, but mine has a dipstick tube. Strangely, the dipstick tube is at the back of the engine by the firewall... Some posters think this is the transmission tube, but no, that is in the same place, but lower down and not visible with the engine cover on. I took a photo to show the difference. My oil change was successful. I sucked about 8L out through the top.

See photo.


Will
 

Attachments

·
Registered
Joined
·
1 Posts
Today I decided to try a topside oil change where you siphon out the old oil with an extractor (mityvac). This on a USA 2001 C240 with a M112 V6. Of course this year/model doesn't have a dipstick, but mine has a dipstick tube. Strangely, the dipstick tube is at the back of the engine by the firewall... Some posters think this is the transmission tube, but no, that is in the same place, but lower down and not visible with the engine cover on. I took a photo to show the difference. My oil change was successful. I sucked about 8L out through the top.

See photo.


Will
Once you do a topside oil change you will never "go down" again to open the drain plug. The one gallon can with the vacuum pump gets nearly all the oil out. Mobil 1 will never form sludge so this should negate the reason to open the drain. Excellent photo showing the missing dipstick cover to remove.
 

·
Registered
Joined
·
8 Posts
Can anyone help me!! I have a 2002 C240.. I have never had any major problems with it but for some reason I drove 80 miles yesterday and when I got home there was nothing wrong then about 30 minutes later I went outside and it would turn over but not start then about 15 minutes later it started so I went to drive it to town and it only went about 3 miles and then died again then started about 45 minutes later but with the check engine light on.. Checked all of the fuel pump relay switches in the back they seemed hot when they put some engine starter on it it tried to start.. People are telling me it's either the fuel filter, or the CPS, or worst the fuel pump, I live out in the middle of nowhere 60 miles to the nearest town I'm a single mom and this is my only vehicle any suggestions would be very very appreciated!
 

·
Registered
Joined
·
11 Posts
Excellent DIY's..!! is there a DIY for servicing/replacing a heated oxygen sensor on banks 2 &1 (HOSB1)(HOSB2)?
Thanks
 

·
Registered
Joined
·
15 Posts
01 C240 oil change, topside, successful, I thought. Then I got an oil too full message and to reduce the amount. Now, however the tube I used to suck the oil out will no longer go down far enough to draw any oil out. The tube bottoms out. Anyone have an explanation? How much trouble am I in?

I use the suction tubing that came with the top sider device, with ice maker tubing at the end for a fit down the dipstick opening. Always worked fine until yesterday.

That fancy oil level check this forum pointed me to varies from 7.8 qts. to 8.3
 

·
Registered
Joined
·
7 Posts
MAF Sensor Cleaning

Hi Guys

Can any of you please assist.

I have a 2006 C220CDI and I'm looking into cleaning the Mass Air Flow sensor.

Please can you advise on what to use to clean this out and if anyone can provide any precautions to be noted when doing so id really appreciate it

Thanks guys.
 

·
Registered
Joined
·
24 Posts
i am in the process of trying to change my cps, but to get to it, I need to remove the MAF. I have an 04 C320 by the way. Please guide me step ,by step to remove the MAF. How do i take the plastic ring off that is holding it in place, is there a snap plastic notch i don't know. The metal clip on the back, do i Lift it up and try to wiggle it off, pull it upwards...please step by step...then finally i can probobly somehow have a tiny more space to try to get my short arms to where the CPS is probobly located...very, very tight to get to.. i don't know they say it took 20-30 min to remove and install...I'm on day 4 on this car...please respond kindly and again step by step, the ones that are posted are too generic...rremove this,then that but doesn't tell you how to remove it....
for those changing the TPS, please note that you can more easily access it from underneath the car if you have good safety stands to keep the car high enough. This will require removing the silver colored heat shield that is on the left side of the car next to the firewall. But, when you do so, accessing the TPS is much easier. I did it from the top and it took forever; watched a mechanic do it from underneath and it was much easier.
 
41 - 52 of 52 Posts
Top