Mercedes-Benz Forum banner

1 - 20 of 27 Posts

·
Registered
2000SL 500 Designo Edition
Joined
·
93 Posts
Discussion Starter #1
Hello Im a newbie here! I have a 2000 sl500 that I bought last summer . I love the car & had a blast driving it last summer. I put it away in great shape.
But this spring I noticed that while it was sitting in the garage it leaked trans fluid. It appears to be comming from the trans pan gasket but Im not really sure.I was able to take the dipstick cap off the tube but I have no way of checking the fluid level. Also what type of fluid do I refill it with ?

Im looking for any help , thanks all , Polpower
 

·
Premium Member
Black SL 500 1994
Joined
·
1,026 Posts

·
Banned
Y2K SL500 Silver
Joined
·
8,660 Posts
Polpower said:
Hello Im a newbie here! I have a 2000 sl500 that I bought last summer. I noticed that while it was sitting in the garage it leaked trans fluid. It appears to be comming from the trans pan gasket but Im not really sure.I was able to take the dipstick cap off the tube but I have no way of checking the fluid level. Also what type of fluid do I refill it with?
Please reply with the mileage on your car. Your problem sounds similiar to what I went through on my 2000 SL500 with 25K miles at 7 years old. FWIW, I have seen other posts with this same problem at about 25K miles. See http://www.benzworld.org/forums/r129-sl-class/1294408-722-624-transmission-leak.html?highlight=722.6
 

·
Registered
2000SL 500 Designo Edition
Joined
·
93 Posts
Discussion Starter #4
Its got about 45k on it ,, I bought it with 35 k on it early last spring . She runs great and is in pretty fine shape. Im really bummed over this.
 

·
Registered
2000SL 500 Designo Edition
Joined
·
93 Posts
Discussion Starter #8
yep I sure did ,, thats my first plan of action ,, thanks a ton. Does your sl have the carbon fiber int ?
 

·
Registered
1999 ML320
Joined
·
24,029 Posts
Given that the problem is pervasive for 722.6 transmissions
and can kill the ECU, why isn't this a recall ?

ErikFinn said:
 

·
Registered
2000SL 500 Designo Edition
Joined
·
93 Posts
Discussion Starter #11
Man I wish it was ,, Im almost scared what will happen when I store it this winter
 

·
Registered
1995 sl 500 red/black w/renntech wheels
Joined
·
686 Posts
I am going through the same problem, like i mentioned before in one of my other threads it was leaking under the oil pan , i looked at the transmission fluid level it was ok , it was hard to steer tho so i took a look at my steering fluid and it was empty i put some in there and no problem with steering but there is a leak somewhere next to the transmission oil pan but its not missing any tranny fluid.:confused:
 

·
Registered
1995 sl 500 red/black w/renntech wheels
Joined
·
686 Posts
I read in one of the posts/threads that there is an O ring that some one replaced can someone tell me where it is? a pic a diagram anything helps.
 

·
Banned
Y2K SL500 Silver
Joined
·
8,660 Posts
tjobeid said:
I read in one of the posts/threads that there is an O ring that some one replaced can someone tell me where it is? a pic a diagram anything helps.
Oh boy, you gotta read this complete string because ErikFinn answered your question in #2 above by pointing to my write up at http://www.benzworld.org/forums/r129-sl-class/1294408-722-624-transmission-leak.html?highlight=722.6

Come on guys, Search='transmission leak' and Read until your eyes hurt. We have already touched on this stuff before. How simple can we make it. Especially when I get questions about the Soft top system or controller and I took the time to bring everything together into one big list and posted it as a Sticky.
 

·
Registered
1987 560SL Gone but not forgotten! & 1999 SL500 For Now
Joined
·
745 Posts
tjobeid said:
I am going through the same problem, like i mentioned before in one of my other threads it was leaking under the oil pan , i looked at the transmission fluid level it was ok , it was hard to steer tho so i took a look at my steering fluid and it was empty i put some in there and no problem with steering but there is a leak somewhere next to the transmission oil pan but its not missing any tranny fluid.:confused:
Then I'd say you answered your own question...your steering pump, hoses, or box is leaking, not the trans.

Bob
 

·
Registered
1987 560SL Gone but not forgotten! & 1999 SL500 For Now
Joined
·
745 Posts
snowbilt said:
How did you check the tranmission fluid? There is no dipstick, it is a sealed transmission.
Even in the so-called sealed transmissins, MB removed the dipstick, left the dipstick tube in place and capped it. You need to have a 'special tool' that resembles speedometer cable with a plastic gradation plate at the end with Min & Max lines marked on it to measure the fluid level. Tool is available on line for $20-$25.

Bob
 

·
Registered
1995 sl 500 red/black w/renntech wheels
Joined
·
686 Posts
So then what is the dipstick in the back of the motor with the big red cap??:confused:
 
1 - 20 of 27 Posts
Top