Mercedes-Benz Forum banner

1 - 20 of 23 Posts

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #1
I have been having starting issues with my 2000 s500 since a few days ago in the morning. It would crank for 5-6 seconds , worried it would burnout the starter i would stop it . I attempted cranking several times with no luck. Also checked for blown fuses hoping it would be an obvious problem. After 20 minutes of not finding nothing decided to try starting it one last time. Car started and worked fine for that whole day. Next morning same thing but this time it didnt turn over at all. I took battery out n got it tested apparently it was bad. Got a reconstructed h8 AGM battery installed it and it cranks now but wont start . Upon taking the cap at the end of fuel rail and turning key to first position fuel spits out, so i know fuel is getting to injectors. I threw a bit of gas through carburetor and it starts but as soon as it burns it shuts off. I tried to accelerate a bit to keep it on but it still shuts off.Im stumped to what could be the cause?
 

·
Registered
2004 S430 W220
Joined
·
13 Posts
You might want to check your crank position sensor.
Kent Bergsma shows us some examples.
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #3
You might want to check your crank position sensor.
Kent Bergsma shows us some examples.
Yea thanks. i just got it delivered yesterday .i ordered the bosch OEM one just havent got to it yet, will probably do it on my day off on Sunday.
 

·
W220 Moderator
Joined
·
7,361 Posts
Moderator Request ....

Welcome to Benzworld.
Please update your user CP info....

click on your icon----> click on Account Settings---->
go to Account Details----> add vehicle details---->
ADD your make and model YEAR ---->
Add your Territorial Location ---->
click save

Read ALL of our stickies before posting, especially the New Guy Sticky.
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #5
Moderator Request ....

Welcome to Benzworld.
Please update your user CP info....

click on your icon----> click on Account Settings---->
go to Account Details----> add vehicle details---->
ADD your make and model YEAR ---->
Add your Territorial Location ---->
click save

Read ALL of our stickies before posting, especially the New Guy Sticky.
Sorry didnt know theres a new guy sticky. I messaged people here before but never posted
 

·
Registered
S500 4Matic 2005
Joined
·
1,055 Posts
Sorry didnt know theres a new guy sticky. I messaged people here before but never posted
Install the Crank Sensor first since you have it and see how it goes. If not post your location and maybe one of us that are local can help with a STAR. That way you do not have to keep throwing parts at it...
 

·
W220 Moderator
Joined
·
7,361 Posts
Sorry didnt know theres a new guy sticky. I messaged people here before but never posted
It's no problem, just a forum rule, I see you've ben on BW a while, just got missed that's all ;)

Thanks for sorting it :)

I posted some info about Immo in the other thread, it's old so i closed it as you have this one, if the Car Cranks it isn't Immo ;)
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #8
Install the Crank Sensor first since you have it and see how it goes. If not post your location and maybe one of us that are local can help with a STAR. That way you do not have to keep throwing parts at it...
Yea just finished putting in the new crankshaft shaft sensor . Its still the same though, cranks but no start. Almost wanna say it seemed to crank slower with new sensor.
 

·
W220 Moderator
Joined
·
7,361 Posts
Have you verified that the Fuel Pump runs upon switching Ignition on ?

...............

This would be a whole lot easier if you owned SDS, as with everyone else who doesn't ;)
 
  • Like
Reactions: doni01

·
Registered
S500 4Matic 2005
Joined
·
1,055 Posts
...............

This would be a whole lot easier if you owned SDS, as with everyone else who doesn't ;)
[/QQUOTE
...............

This would be a whole lot easier if you owned SDS, as with everyone else who doesn't ;)
^^ Yes it would!! But people rather keep throwing parts at it then getting one.

Dyablos500, where are you located??
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #12
^^ Yes it would!! But people rather keep throwing parts at it then getting one.

Dyablos500, where are you located??
Im in Everett, Washington. No i haven't exactly verified if pump runs but i can hear it when i turn key to #2 position .im going to try and check fuel pressure at rail but i cant find what bar is should be at ?
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #13
Your battery is getting weak by all the starting attempts . If you have a charger charge it
Possibly but havent really tried cranking it over really. Only about 3x , once to show my mechanic friend and 2x after installing cps
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #14
Update after using a basic obd2 scanner owned by my friend , had a few such as B1000-00( under voltage of headlight range adjustment), B1315 (problem with front passenger child recognition), B1875 - couldn't find anything of this code . Also im not sure if relevant but i noticed the magnet on old cps was stronger than the new Bosch sensor we installed- could this be an indication of it not being good?
 

·
W220 Moderator
Joined
·
7,361 Posts
Update after using a basic obd2 scanner owned by my friend
That is why you need SDS, you are not seeing hardly any Modules and only a small percentage of Codes in a very few Modules ;)

Cheap Scanners are useless, lead you up the garden Path on Wild Goose Chases they will ;)

Still needs the Battery charged, and Fuel Pump verified correctly !!

When you have done that and got us a decent read and posted all the Codes and relevant Data, then we can help you.
Any other replies will just be conjecture, because the complex computer network controlled Vehicle has not been diagnosed properly.

The Crystal Ball isn't working atm.
The other day it said charge the Battery and check the Fuel Pump is working, neither of which you have done :(
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #16
That is why you need SDS, you are not seeing hardly any Modules and only a small percentage of Codes in a very few Modules ;)

Cheap Scanners are useless, lead you up the garden Path on Wild Goose Chases they will ;)

Still needs the Battery charged, and Fuel Pump verified correctly !!

When you have done that and got us a decent read and posted all the Codes and relevant Data, then we can help you.
Any other replies will just be conjecture, because the complex computer network controlled Vehicle has not been diagnosed properly.

The Crystal Ball isn't working atm.
The other day it said charge the Battery and check the Fuel Pump is working, neither of which you have done :(
Sorry I apologize im not mechanically inclined i know basic stuff but i try so by verifying the pump what exactly do you mean? I did do a fuel pressure test by the fuel rail and got barely 50psi while cranking. It was around 40 i believe when priming. And i did have a booster on battery while working on it (didnt have an voltmeter but headlights never dimmed/ battery seemed strong) .I know the scanner i used wasn't a SDS but i was trying to use limited resources i had at the time.Didnt have a chance to jack car up and test pump today. but after putting starter fluid I was able to get car to start.It idle pretty rough for about 5 min, I drove it around to get food and came back .Im sure it won't start later on again as it did the same thing when the issues first began. As for the SDS found some on Amazon yet im not sure if these will work can you check them out and see if you think they're good please
Thanks in Advance
 

·
Registered
Too many to list
Joined
·
9,577 Posts
Well one you posted is just a Box to hold a scanner . These are not sds machines

a sds machine is a full laptop computer with a multiplexer and cables . Will cost you $600-800. I can already tell you aren’t going to do that
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #18
Screenshot_20201123-015106_Chrome.jpg
Yea theres actually 2 links there.i dont know why i posted the link for the box lol.and you mean something like this
 

·
W220 Moderator
Joined
·
7,361 Posts
This was the last reference to fuel test .............
No i haven't exactly verified if pump runs but i can hear it when i turn key to #2 position .im going to try and check fuel pressure at rail but i cant find what bar is should be at ?
I'm not psychic, but now I know you got 40 to 50 psi it should fire up, so now you have eliminated Pump / Relay, blockage etc etc etc etc.
I am surprised you found the correct fitting for attaching the Gauge to the Fuel Rail though, as a lot of regular test kits don't contain that fitting ;)

There are now at least 100 other reasons it won't start it is time for SDS.

That machine above is fine, that is SDS .............. Star Diagnostic System is the only machine for Mercedes Cars, and it is way more than just a reader resetter. It pays for itself on faults like this.

I have no agenda to sell you SDS, I am trying to save you money, not cost you. You can easily waste more than that SDS cost on just one issue like this,

HTH :)
 

·
Registered
2000 s500 w220 benz
Joined
·
21 Posts
Discussion Starter #20
This was the last reference to fuel test .............


I'm not psychic, but now I know you got 40 to 50 psi it should fire up, so now you have eliminated Pump / Relay, blockage etc etc etc etc.
I am surprised you found the correct fitting for attaching the Gauge to the Fuel Rail though, as a lot of regular test kits don't contain that fitting ;)

There are now at least 100 other reasons it won't start it is time for SDS.

That machine above is fine, that is SDS .............. Star Diagnostic System is the only machine for Mercedes Cars, and it is way more than just a reader resetter. It pays for itself on faults like this.

I have no agenda to sell you SDS, I am trying to save you money, not cost you. You can easily waste more than that SDS cost on just one issue like this,

HTH :)
Yeah guess i got lucky with the fitting.It was still attached to the gauge when i opened the kit. As for SDS i normally wouldn't have to think twice about purchasing it but due to my current situation, i am a bit hesitant. To be honest i was laid off 2 months ago and just had some medical issues which set me back. I will be able to buy SDS in a few weeks yet since this my daily driver at the moment , I am desperate to get it in tip top shape again. Ive called MB dealer to get it scanned properly for $199 tomorrow. I will update tomorrow with proper codes .Thanks (y)
 
1 - 20 of 23 Posts
Top