Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
2000 Mercedes S430 80k miles Black on Dove Grey 20 inch rims.
Joined
·
1 Posts
Discussion Starter #1
HELLO EVERYONE!!!!

I AM NEW TO THE FORUMS AS AN ACTIVE USER SO MAYBE SOMEONE HERE CAN SHED SOME LIGHT TO MY ISSUES ON MY 2000 MERCEDES S430 80K MILES.

JUST RECENTLY OUT OF THE BLUE MY CAR WAS DRIVING BEAUTIFULLY! WHEN OUT OF NO WHERE IT WAS SOUNDED AS IF SOMETHING SNAPPED BY THE REAR WHEEL AND THEN STARTED MAKING A SLIGHTLY HIGHER THAN NORMAL REVING NOISE THEN IT STARTED CLUNKING WHEN I TURNED? DID MY TRANNY GO OUT? OR IS IT A SENSOR? SOLENOID? WHAT CAN IT BE I HAD A MERCEDES MECHANINC TELL ME I NEED A TRANNY I HAVE A GUT FEELING I DONT NEED ONE. WHEN I PUT IT INTO DRIVE AND TRY TO USE SLAP GEAR SELECTOR IT STAYS IN DRIVE. I TRIED TO DRIVE IT TO SAFETY AND NOTICED IT WONT GO OUT OF FIRST GEAR AND WHEN I GO PAST 25-30 IT SEEMS AS IF THE TRANNY HAS TO CATCH UP TO THE GEARS SO I HAD TO STOP WAIT 45 SECONDS AND THEN IT WENT BACK INTO GEAR DOES ANYONE KNOW WHAT IT MAY BE? PLEASE HELP OR CALL ME ILL TAKE CALLS


ALEX
505-453-1862
 

·
Registered
2000 S430
Joined
·
26 Posts
Was there any control malfunction error messages on your display?
What is the mileage of your vehicle?
Have you ever had the transmission oil, filter, magnet, etc. changed?
Did you check underneath the transmission pan for oil leaks?
Did you check for tranny oil on the Transmission Control Module (TCM) located inside one of the fuse holder panels in the engine compartment?
How did the technician come to the conclusion that you needed a new transmission?
 

·
Registered
2000 and 2003 W220 S500
Joined
·
930 Posts
The car is in limp mode.
It will not leave that mode until the codes are cleared.

If the sound is from the rear though, it sounds like the differential is messed up.
 
1 - 4 of 4 Posts
Top