Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1997 E420 & E320
Joined
·
83 Posts
Discussion Starter #1
2000 S430 178K miles

The car will go into all the gears with the shifter.

P
R
N
D

The car will not shift pass 1st gear. I have not connected the CarSoft to it but it looks like the tranny is in LIMP MODE. I was told by the previous owner that he disconnected the Neutral Switch??? I think he means the Parking safety switch. He stated that an MB shop told him a new shifter will solve the problem.

My question is the following one:
Will the shifter issue cause this tranny problem?

I thought the shifter problems would only prevent you from going into gear, if you were able to get it into D, the rest is managed by the tranny. If it does not go pass 1st gear that points to a tranny problem and not a shifter problem.

Thanks for any input. It is much appreciated.
 

·
Registered
10 Mercedes e350, 09 Mercedes GL450, 95 BMW 325IC, 89 Mercedes 260E, 84 Euro Mercedes 300D 4spd
Joined
·
645 Posts
Sims like your car in the limp mode,
Take it to the shop to get it programed
 

·
Registered
1997 E420 & E320
Joined
·
83 Posts
Discussion Starter #3
Sims like your car in the limp mode,
Take it to the shop to get it programed
agreed. Now, my background is from the W210 chassis. As I understand it, Limp mode will clear up when you reset the codes with CarSoft but it will return when the codes are generated again by the problem.

Can a shifter issue trigger the tranny to go into Limp Mode?

What do you mean to get it programmed? do you mean reset the codes?

thanks
 

·
Registered
2002 honda civic (sold), 2009 Mercedes ML350
Joined
·
1,344 Posts
a shifter has no effect on the trans shifting gears. a car staying in first gear is either caused by low fluid level or an electrical issue, bad speed sensor usually.
 
1 - 5 of 5 Posts
Top