Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Greetings, I wonder if anyone can help me?<br> <br> Last night while driving, it sounded like the CD I was playing skipped, but it made a 'Tthipp' sound and just died... I at first thought it was overheated (it being 95 degrees) so i turned the radio off.... Later on that night I hit the CD button and the LED screen read 'NO CD CHANGER'<br> I...<br> 1. Checked the main fuse compartment under the hood and both stereo fuses are fine... and <br> 2. Checked the CD carriage and no CD's are stuck<br> <br> The weird part is the carriage will eject fine, but when i re-insert it, it does nothing (no noise of loading, etc)<br> <br> My question is: I have 3 other fuse boxes... is it possible there is another stereo fuse hiding that I haven't found?<br> <br> Or is it a more serious problem?<br> <br> Any information would be helpful.<br> <br> Best regards,<br> --Chris
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
Who installed the changer? If the dealer doesn't reprogram the D2B bus for the changer, error codes will build up in memory until the unit stops working. I don't know if this is your problem, but it is a place to start.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
Thanks Lynn...<br>
<br>
I took it to the dealer ( since I bought it from a private owner, I wasn't sure if the warranty transferred) but it did... and they had to put a new head unit in.<br>
<br>
So, all is good now.<br>
-C.
 
1 - 3 of 3 Posts
Top