Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Two of the largest dealers in the Boston area have denied repair of this problem even though advised that a service bulletin exists to correct the problem. Approx. 6 months ago I believe someone posted the service bulletin reference number. Can anyone help?<br> <br> Thanks, Walter H.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
Well Mercedes would not call it a recall but if the customer complains about the strength of the A/C they will replace the entire system with the upgraded (larger evaporator coil) system under warranty. It is a very big job, must take entire dash apart, but let me tell you it is worth it. The new A/C actually cools the car. We had the entire air conditioning system replaced in our MY2000 S430 (April 1999 delivery) under warranty. The new systems have 'AC off' on the 'EC' button; the old ones don't. Good luck ..... your service guys should know all about this but complain to your sales guy and have him pressure Service to fix it.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
Well...<br>
<br>
I did not like the output of my A/C on my 2000 S500. Called the dealer, told him I had heard of a problem.<br>
<br>
He said any S500 built before 11/99 is eligible. Mine was built on 07/08/99. So made an appointment for next week and they are going to do the job. He said it is a big job.<br>
<br>
Push the dealer if you are eligible. If you do not get any satisfaction from them contact MBUSA directly. Usually when they get involved, matters get resolved quickly.<br>
<br>
Good Luck
 

·
Registered
Joined
·
0 Posts
Discussion Starter #4
YEH I JUST HAD MY 2000 S-430 UPGRADED TO THE NEW AIR CONDITIONING SYSTEM SEEMS ALOT BETTER AND YOUR RIGHT IT IS A BIG JOB BUT IT'S WORTH IT .
 

·
Registered
Joined
·
1 Posts
I have a 2000 S430 and the AC is not very cold when the engine is at idle or below 2000 RPMs. When I am on the freeway and RPMs are above 2000 the AC runs colder and is good. Also, getting air to the back is a hassle, because the only way to get good air flow to the back (2 vents, plus 2 side vents) is to set the front air off (move the manual dials). At the 1 block setting some air goes to the back but not really enough.

I have had my car worked on by the MBZ dealer and they say they "fixed" something, but I still have the problem at low RPMs.

Does anyone else have this problem?
 

·
Registered
MB CL500(C215);SL55(R129), SL63(R230)
Joined
·
472 Posts
Guest (MBNZ) - 8/7/2002 8:27 PM
YEH I JUST HAD MY 2000 S-430 UPGRADED TO THE NEW AIR CONDITIONING SYSTEM SEEMS ALOT BETTER AND YOUR RIGHT IT IS A BIG JOB BUT IT'S WORTH IT .
Could you please post the part# of the evaporator you have got installed?

A220 830 04 58?


Cheers, Frank
 
1 - 7 of 7 Posts
Top