Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Mercedes-Benz
Joined
·
2,245 Posts
Discussion Starter #1
Hi,
we have a '00 E320 CDI T-modell.
It has 118.000 kms and drives very properly.
Only 2 things I'm wondering about:

-when the car is driven normal (no harsh acc., no high revs) it goes into emergency-running-mode ('noodloop' for the dutch-speaking people). This means the engine doesn't revv over 3000rpm and no hard acc.

-the car has clean exhaustfumes when driven normally, but when the car is in the emerg. running mode, there's always a lot of black smoke coming out.


ofcourse it seems that these two things are in some way connected to each other.


hope to get some response on this.

greetzz

matteus


p.s. I posted this on the W210 Forum already, but nobody answers, I hope there are people here who can help me.
 

·
Registered
(W210) Mercedes E320 CDI YEAR 2000 X reg (MANUAL AIR CON)
Joined
·
89 Posts
Yep, I also experienced the same problem. Not enough oxygen is getting into the engine to burn the diesel properly. You’re AGR (air gas recirculation) part needs to be changed. The part cost about £200 from Mercedes. Or you could try taking the part off cleaning it and lubricate the spring which is causing the problem.

That was the diagnosis for my car; however you could try putting the car on the diagnostic machine just to make sure that’s the part gone on your car. (No error came up on my car though, they said it’s a mechanical fault not an electric one, useless)

Hope info is of some use; write back if you need to know more.

My car is a w210 E320 CDI 2000
 
1 - 2 of 2 Posts
Top