Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1983 300 SD; 2000 E320
Joined
·
1,099 Posts
Discussion Starter · #1 ·
After garaging my SD for the winter my front passenger window didn't work. It's NOT the switch. The motor made no noise when switched on either.

After struggling like a b__ch with the two torx screws that hold the motor on, I was able to pull the motor off. I had to pull and twist hard. When the motor was off it worked!!! I didn't test both directions though.

Then, I put the motor back on, and again it was tough to get it on. I hit the switch and voila the window went up completely!! But then it wouldn't go down. I pried the metal cover off the gear box but the round head/ bulb at the end of the motor drive shaft wants to stay in it's form fitting housing. The only way I can see getting the motor out now is to rotate it so it worms its way down. I can't get the geared teeth to rotate with a screwdriver the way Azimuth did (

Lastly, to get access to the torx screws I unbolted a few of the regulator bolts and flexed the regulator arm a bit. After the window was closed (moved only 1/2") the lowest bolt moved away from the hole. You can see it in the photo, the bottom of the "v" arm. Can I force this back by using a hammer or lever?

Thanks:bowdown:
 

Attachments

·
Registered
1979 280CE
Joined
·
6,118 Posts
Is it the same regulator as a W123? I have a working W123 front passenger window regulator if its the same as your W126..
 

·
Registered
1983 300 SD; 2000 E320
Joined
·
1,099 Posts
Discussion Starter · #3 ·
I believe it's a different regulator, though the motor may be the same
 
1 - 3 of 3 Posts
Top