Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've got a weird problem with the adaptive damping on my '99 SL500.

The ride height on the left side (at all 3 ride height settings, as well as at rest when the car is on its belly) is 10mm higher on the left hand side.

It's quite noticeable (to me anyway), and my maindealer says that there is no facility for adjustment in the system. Have any of you guys noticed the same phenomenon with your suspensions too?
 

·
Registered
1999 SL500 R129
Joined
·
42 Posts
I have the same problem! did you find any answers?

the height adjustment works fine but the front left is 20mm higher than the front right and the rear left is 10mm higher than the rear left.

this is on a RHD car if that makes any difference. I'd say the drivers side may have sagged but to be honest the left actually looks higher than it should, so I think the drivers side is fine but the left has raised up??

I'd love to sort this out, any ideas? anyone?
 

·
Registered
MB SL600, MB 380SE, Suzuki Grand Vitara, 38' Chris-Craft, Volvo V70XC, and my own two feet...
Joined
·
4,131 Posts
Did either one of you do any work to the ADS system? Could be an incomplete bleed.
 

·
Registered
1999 SL500 R129
Joined
·
42 Posts
No, I've done nothing, I only noticed it in the last few days.
It almost seems as though the left side is stuck at level 1, I'll check tomorrow if it raises at all on the left when I switch to level 1, it definitely goes all the way up on level 2.
Is it possible that one side only drops to level 1 not normal? or is this something else?
 

·
Registered
MB SL600, MB 380SE, Suzuki Grand Vitara, 38' Chris-Craft, Volvo V70XC, and my own two feet...
Joined
·
4,131 Posts
Could be a ride height sensor too.
 
1 - 5 of 5 Posts
Top